Previously Downloaded and Uninstalled Anki, now can't reinstall

When I was an undergraduate, I downloaded the Anki app but didn’t use it, so I uninstalled it.

Now I’m in med school, and I can’t seem to download it again. Every time I try to install it, it gives me this error:

An add-on you installed failed to load. If problems persist, please go to the Tools>Add-ons menu, and disable or delete the add-on.

When loading ‘⁨load balancer⁩’:
⁨Traceback (most recent call last):
** File “aqt.addons”, line 246, in loadAddons**
** File “/Users/(my name)/Library/Application Support/Anki2/addons21/1417170896/”, line 1, in **
** from . import loadbalancer**
** File “/Users/(my name)/Library/Application Support/Anki2/addons21/1417170896/”, line 512, in **
** anki.collection._Collection.load = wrap(anki.collection._Collection.load, InitConf, pos=“after”)**
AttributeError: type object ‘Collection’ has no attribute ‘load’

I already went to system settings and developer tools, but there were no add-ons. I also tried all the versions they offer for a Mac download.

What should I do? I need Anki on my desktop to study for med school.

It looks like you installed some add-ons when you used it before that are incompatible with the current version of anki. The easiest think to do is open anki while holding shift and go to the Tools>Add-ons menu, and disable or delete the add-on. Alternatively you can try going into the folder addons21 from the error message and deleting the load balancer addon (folder named 1417170896).


It worked! Thank you so much!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.