Anki Forums

Please use File>Import to import this file

Hi,

Since updating to Anki 2.1.47 and then to 2.1.48 I am getting this message: Please use File>Import to import this file

I have disabled all plugins (I use CrowdAnki, AssetManager Cloze Overlapper; and a few more less important ones) I have run check database etc as well. Has something crept into my file that is giving me this message? Othewise it seems harmless. I click ok and my anki functions normally.

Any ideas what is causing this?

Thanks!!!

Screenshot from 2021-09-25 12-30-11|398x150

If you’re running Anki from a shortcut, this is probably caused by an extra command line argument, which is interpreted as a deck to import by Anki.

1 Like

ah ok this is it… but still a bit weird. I am starting anki with /usr/local/bin/anki --no-sandbox as Anki on Fedora 35 (just into beta) in a container is having an issue with webview (I posted another question on that: Fedora 35 and Anki 2.1.47 updates with blank Anki window

So i guess that --no-sandbox is doing its thing but Anki is also taking that as another file? Anyway I can live with that.

Probably.

Using an env var instead will probably work:

https://doc.qt.io/qt-5/qtwebengine-debugging.html#using-command-line-arguments