Pasting large clipboard contents on Debian GNU/Linux

On Anki 2.0.x, I can paste big texts from GVim and Firefox with no problem.

However, on 2.1.22 (and earlier), pasting from Firefox into the normal editor has some issues:

  • Only a part of the text may have formatting; the rest is pasted as plain text.
  • Texts over a few kilobytes just disappear from clipboard and are not pasted, even if pasting into the HTML editor.
  • When pasting from GVim in the previous case, GVim may crash.


Can you reproduce the issue with the latest alpha?

The problem usually happens with articles with many comments. I had never copied the whole page, but only parts of it, so…

Just tried with 2.1.28alpha3 and
Xorg, Anki and Firefox are started from different user accounts.

Ctrl+A → paste into Anki worked perfectly once (if I am not mistaken).

Selecting content that begins with " IvanVakhrushev 3 июня 2020 в 23:06" and ends with the last line under the " Самое читаемое" section… pasting into Anki just doesn’t happen.

I started an older Firefox from the same account as Anki, and pasting with Ctrl+V did nothing, but when I used Paste in the context menu next moment, it worked.

Pasting into LibreOffice Writer works. Pasting from it into Anki… does not.

I also tried with 2.1.22, and copying from the new Firefox as a different user worked. Maybe the article is a bad example for lost formatting (too few comments? Different CSS?), but at least pasting works both times into .22 and not into the alpha.

Note that sometimes it is hard to select comments at in Firefox: if you move the pointer and unselect the end, selection may be cancelled.

It appears to be taking a long time because of all the avatar images that need to be downloaded. If you disable images or use some JS to remove them prior to pasting, you may be able to work around the issue.

1 Like

No, I am only talking about the time before the images start downloading. Are there silent DNS requests for all of them at first?

Images downloaded as part of a HTML document don’t have a progress window at the moment.