Note Type creates cards with no back

Hello Anki Community,

I am a language learner who loves using Anki. However, recently I have found that cards are being created, which contain no back information. Upon further inspection, it seems that Anki is unable to detect that the field necessary for a card is empty.

I have relied on the feature in anki that detects whether or not there is information to put on a card. This way, I can, for example, add audio to some of the notes which I’ve created, but not have to add audio files to every note. However, now it seems that I must either create special decks for cards with specific fields filled.

The main problem that anki is having is that it only looks at the front of the card, and it makes the card if one of the fields is filled. I need to change this so that a card is only made if all the fields (front and back) are filled.

Please help!

from the 2.1.28 change log:

Card generation changes:

  • Card generation now supports negated conditionals, and a mix of required and optional fields.
  • When adding/importing, if a normal note doesn’t generate any cards, Anki will now add a blank card 1 instead of refusing to add the note.

If you need further clarification please share an example of your back template being empty.

I understand. Is there any way to modify this option?

As of today, downgrading to an older version < 2.1.28

I think Guillem may be thinking of something else - this behaviour is no different in older Anki versions. I have updated the manual to make this clearer.

1 Like

I figured out how to do this. It was actually right in front of me this whole time, but I didn’t use the feature right. Basically, I just used the tools demonstrated in the documentation which you sent me. It was mainly just making {{#Field}} {{/Field}} tags around the face card. After this, I used “delete empty” to get rid of the superfluous cards.
I didn’t have to downgrade, luckily. Thanks for all your guys’ help.