Not able to export


I run the latest version of Anki on Windows 10. Whenever I try to export my master I get the following error:

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.42 (8eebfe18) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2021-03-22 13:35:20

Caught exception:
Traceback (most recent call last):
File “aqt\”, line 88, in _on_closures_pending
File “aqt\”, line 59, in
File “aqt\”, line 172, in on_done
File “concurrent\”, line 432, in result
File “concurrent\”, line 388, in _get_result
File “concurrent\futures\”, line 57, in run
File “aqt\”, line 166, in do_export
File “anki\”, line 340, in exportInto
File “anki\”, line 348, in doExport
File “anki\”, line 250, in exportInto
File “anki\”, line 246, in update
File “anki_backend\”, line 488, in add_or_update_notetype
File "anki_backend_init
.py", line 106, in _run_command
anki.errors.TemplateError: Card template ⁨3⁩ has a problem.

Can someone please tell me how to fix it? I tried with and without add-ons and checked the database.
Any help is appreciated, thank you.

1 Like

anki.errors.TemplateError: Card template ⁨3⁩ has a problem.

Can you share the third card type of the template the cards you want to export have?


If you edit one of the cards, click on Cards, and select the third template at the top, you’ll be shown an error that you need to fix.

1 Like

Thank you for your answers. I want to export my whole collection. So I guess that you mean the third template in the browser?

It is actually just a simple basic note type. I guess the weird name comes from the fact, that I imported that note type from a previous version of anki?

Here it is:

Screenshot 2021-03-23 164837

Select the third card type from the selector at the top of the card types screen.
Since you’re exporting your whole collection, you have to figure out which note type that has a third template is causing the problem.

(maybe the error message can be improved by including the note type name)