Error occurring when trying to export

Hi there,

I’ve already tried restarting Anki, restarting with no Addons (holding the shift key down), etc. and still no luck.

Here is the message I receive:

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.46 (94913ec2) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-08-19 07:59:08

Caught exception:
Traceback (most recent call last):
File “aqt/”, line 101, in _on_closures_pending
File “aqt/”, line 71, in
File “aqt/”, line 173, in on_done
File “concurrent/futures/”, line 432, in result
File “concurrent/futures/”, line 388, in __get_result
File “concurrent/futures/”, line 57, in run
File “aqt/”, line 167, in do_export
File “anki/”, line 342, in exportInto
File “anki/”, line 350, in doExport
File “anki/”, line 253, in exportInto
File “anki/”, line 539, in update
File “anki/_backend/”, line 450, in add_or_update_notetype
File “anki/_backend/”, line 131, in _run_command
anki.errors.TemplateError: Card template ⁨1⁩ in notetype ‘⁨Cloze-df79c⁩’ has a problem.
See the preview for more information.

I would appreciate any sort of help as to how I can fix this. Thank you.

As the error message says, a card template in the notetype named “⁨Cloze-df79c⁩” has a problem that you can inspect in the preview screen (Click Cards when in the editor). Anki should show more info in that screen. You can also copy and paste your template content and post it here.

1 Like

Oh, I see!

So the back template for that Note type had the following:



(with spaces signifying br’s for breaks)

When I was previewing the card it said something along the lines of there being no “Summary” so all I think I have to do is just delete {{hint:Summary}} from that line of code and that should be it, right?

Yes, I think this should solve the issue.

Seemed to have worked! Thanks!