New cards saved in different decks (macOS)


I have Anki on both my Mac and iPhone.

Using the desktop mac version, with the latest version, when I create a new card, it isn’t stored in the currently selected deck. Instead it is saved twice, in two different decks instead of the active one.

After reading the support info, you said to use the Database Check option. Hard to find, it’s only on the smartphone version. It didn’t detect any trouble.

But the card are still not saved in the correct deck…
Any idea on how to fix this? It’s totally blocking.

When adding a card to Deck A, it should not be saved in G and P


In the Add screen, click Cards, then Options, and make sure the Deck override option is off for all your card types.

The Check Database option is in the Tools menu.


1 Like

But it never worked this way.
When I picked a deck, then added cards, those ones were added in that deck, the current one.
In the Add card, even the Deck option correctly names the current deck. But it’s just decoration, it’s useless.
Now each time I switch to another Deck/Package, I have to go to the Options menu and tell it where to store the cards. Why?
Why doesn’t it store the cards in the active deck that is mentioned in the Add Card window itself?
When changing to a new deck, the Options still points to the previous one.
It’s totally counter intuitive and makes absolutely no sense.

You don’t have to use the deck override option if you don’t want. But you may have activated it accidentally so I suggested checking that it’s off.
Does the issue happen with a specific note type?

Thanks for the input.
But how do you deactivate it?
Absolutely all of my notes, no matter what kind, are saved in the last deck selected in your operation.
If I switch to a new deck, and start adding cards in that deck, with the correct deck name shown in the “Deck” option, they’re saved in the previous deck.
Switching decks should make the new deck the default for saving new cards, shouldn’t it?


After clicking the deck override option, leave the input box blank to disable the option.


1 Like

I tried to leave it blank.
When I come back it says “all” and still shows it’s on
Is that enough? “All” means “currently selected deck” ?

(I’m on a Mac)

That’s strange. Do you have a deck named “all”? Can you make a screenshot of what you see?
I’m not really sure why it stays on.

No, no deck named “all”.
I fully uninstalled, removed all traces from Application Support, Preferences, Containers, etc
Reinstalled. Works now… Strange :slight_smile:
It says “Override off” and cards are added to the current deck as expected.
Thanks for your help