M1 Chip new book air

hi guys,

do you think anki can be used without any problems with the new M1 Chip in the macbooks?

Anki will probably not work on the new Macs straight away - there are apparently problems with the web toolkit that Anki is built on that prevent it from running under Rosetta 2. I expect they will fix this, but it may take a little while.

Thank you for answering!!
What do you think how much time will it take to beable to use anki?

Since the issue is in upstream components and I don’t have my hands on the new hardware yet, it is hard to say. Another page I read today seems to imply that it may in fact work out of the box, and that the issue was only on Apple’s development machines - we’ll need to wait and see.

I just got the new Macbook Pro with the M1 chip and it appears that the desktop anki app does not work and is unable to open. There is a work around though, as I downloaded AnkiMobile onto my laptop which does work but it is not as user friendly. Was wondering if there’s an estimated timeline of when the desktop app will be updated for the M1 chip?

Additionally, since I don’t have access to the desktop app anymore I was wondering if anyone knew how to create subdecks in AnkiMobile and/or AnkiWeb? Thanks!

I’m fairly sure you can use double colons :: to create subdecks. For example, say you already have a deck named “Parent”, you can create a new deck named “Parent::Child” and this new deck will automatically become a subdeck of “Parent”.

I’m still waiting for a new Mac Mini to arrive, so I have not yet been able to test this myself, but I saw someone on another forum post that Anki was working for them on their new device. What happens when you run it on your machine? I presume you tested with 2.1.35?

1 Like

@Anki3, check some settings, Console logs as well as that Rosetta 2 has been installed.
The first time I opened an Intel-based app, it waited for a while, then asked me to install Rosetta.

Anki works fine for me on M1 MBP.

1 Like

Yes, I tested with 2.1.35. When I click on it, it just never opens and my cursor becomes the rainbow spinning wheel indefinitely. The only way to stop it is to force quit Anki.

I am pretty sure I have Rosetta installed as I have been running intel apps like Microsoft office apps. How do I check console logs?

Mac Mini arrived, and after getting it set up, Anki opened successfully for me. Did you drag it into your Applications folder first? If you’re trying to run it directly from the dmg, it may be slow. Have you tried restarting your machine?

1 Like

Try the following:

  1. in Finder, Applications -> Utilities
  2. Find “Console” there
  3. Click “Start” (or “Stream”), start Anki. Then click “Stop” on the same button
  4. Search for “Anki”
  5. somehow it showed more than just Anki’s logs, so sort by the process if needed

Other troubleshooting steps:

  • if restored from a backup and have addons there, try to start Anki while holding “Shift” button, it will disable sync and prevent from loading addons;
  • if doesn’t help, try to wipe Anki and its caches (CleanMyMac X might help with that) and reinstall from scratch.


another hint of the problem can be found in crash.log, open Terminal.app and copy/paste there:

open /System/Applications/TextEdit.app Library/Application\ Support/Anki2/crash.log

@Anki270 @dae Thank you so much!!! Not sure what the exact fix was but I tried all of your suggestions and redownloaded Anki and it opened just fine!