Looking for version without the new Qt problems

Hello and thanks for this software, it is really an essential tool.
I have tried to update my version on windows, and the new version, having worked for about 2 days, now crashes relentlessly.
I have tried:
23.12.1, 23.10.1, 2.1.66, 2.1.61, version qt6, qt5
Only version 2.1.36 seems to work.
Now it cannot read the backup I had done previously because it is too old.

Can someone tell me the earliest version that changed the backup system, so I can try it and recover my learning state?
Thank you so much, xgiannak

You shouldn’t be getting relentless crashes in any of those versions. What version did you upgrade from? Have you tried everything on the Troubleshooting checklist? Troubleshooting - Anki Manual

1 Like
  1. restart Anki : Anki has been restarted multiple times, also uninstalled, cleaned and reinstalled
  2. add-ons : there is no add-ons
  3. Anki version : 23.12.1 windows qt6 (but see list above)
  4. check database : it is empty
  5. restart pc : just restarted after uninstalling
  6. change video driver : tried Direct3D, OpenGL, Software. Vulkan no because it crashes at start.
  7. reset window sizes : done
    Other questions: upgrade from 2.1.54
    Here is the error in event log:
    Faulting application name: anki.exe, version: 0.0.0.0, time stamp: 0x658d3852
    Faulting module name: Qt6WebEngineCore.dll, version: 6.6.1.0, time stamp: 0x655bd4f6
    Exception code: 0xc0000005
    Fault offset: 0x0000000000290a83
    Faulting process id: 0x0x2C04
    Faulting application start time: 0x0x1DA58E438CAE031
    Faulting application path: c:\users\xgiannak\appdata\local\programs\anki\anki.exe
    Faulting module path: C:\Users\xgiannak\AppData\Local\Programs\Anki\lib\PyQt6\Qt6\bin\Qt6WebEngineCore.dll
    Report Id: bed3868e-1bf6-4499-a2f7-91a94a5de1c1
    Faulting package full name:
    Faulting package-relative application ID:

Thanks so much for your interest. xgiannak

Thank you for those additional details. That helps focus the issue.

  • What version of Windows are you using?
  • That event log specifically refs Qt6, so I was going to suggest Qt5 – but it sounds like you already tried that. What was the log message with Qt5?

Thank you again, I am using Windows 11 Enterprise Version 23H2 (os build 22631.3007).
About the log message with Qt5, give me one day to uninstall, reinstall and try.
Best regards, xgiannak