Keep getting "Bad Request" while learning a deck in Ankiweb

I am learning a deck on Anki Web. The deck I am learning is a filtered deck derived from another. Often when I click the the “Easy” button, I get this:

Then I have to refresh the page, often finding that some of the last cards I learned come up again as if the progress has been set back. The error message only seems to pop up when I click the Easy button.

FYI Here is the details regarding the filtered deck:

And here are details the filtered deck is based on:

Extra details:

  • I am using Chrome (most up to date) on Ubuntu
  • I have tried clearing cookies and it still happens

This came up a few months ago too. The primary post seemed to be an FSRS bug, which wouldn’t be your issue. But another user posted about what helped them –

If you refresh the page and go through the same cards again, does answering Easy the second time result in the same error, or does it work the second time?

yes it usually always works the second time (I can’t recall a time where it hasn’t).

Also some insight: When I press any of the other buttons (aside from Easy), the respective card always stays assigned to the filtered deck in Learn mode, regardless of how many times I come across it and click a non-easy button (I’m not sure how/why this works like this; I’m sure you have better understanding around this). When I press Easy for a card (and it works without error), it is assigned to the underlying deck in Review mode.

So the problem may have some thing to do with that switching of decks?

The error message unfortunately doesn’t reveal the problem, so ideally, I’d like to be able to reproduce this issue. I tried running through a few hundred of your cards in a copy of your deck, but couldn’t seem to trigger it, so there may be going on here - perhaps it depends on the answer you give prior to rating easy, or the speed at which you’re answering. I have some updates I need to push out to AnkiWeb soon, so it might be worth waiting to see if they help - I’ll post back here once the update has been done.

1 Like

this issue hasn’t happened for a day or two at the moment, so it seems to be intermittent

1 Like

I managed to catch some trace in chrome while it happened this time, dno if this means anything to you?

In this case I’m afraid that doesn’t help, as I could already see the error on the server end - but not exactly what is causing it. In the mean time, refreshing the page should allow you to continue studying, and it shouldn’t cause any permanent harm.