json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

probably you can install 2 versions on different windows user account. (don’t know tho, have never tried it)
but you can’t have 2 versions on the same windows user account.

1 Like

Okay I see XD

Thanks a lot! Yes, I will probably export my previous decks to 2.1.22 version

I indeed do this. Perhaps my case is somewhat useful for you. I currently have 3 different Anki versions installed that I use in a daily basis. I use a different Anki profile for each one, but I am using the same Windows user account.

If you want to use the same Anki profile with different versions, that is also possible. I have done it in the past were I was relying on add-ons some of them compatible with older or newer versions. So I was switching versions depending on the use I wanted in that particular moment. The only difference is that now >2.1.24 requires to click downgrade and click each time you may switch Anki older versions.

4 Likes

Is there some tutorial how to install two versions?

well, i didn’t think about this.
but you’re right, no need to have multiple windows users.
but you have to change the path where it installs, is this how you do it?

1 Like

Yes, for instance Anki2115, ANki2122, Anki2126, AnkiBeta,etc.

Although not strictly needed, I use custom startup options to bypass the profile selection.

3 Likes

nice :smiley:
didn’t think about this, it’ll definitely come in handy :+1:

1 Like

In the manual you have the info for the startup options. You just need to change the folder where you install Anki so you do not override the installed versions. It may be sound complicated with it is really easy in fact.

1 Like

Specially for beta versions, which usually you will use for a couple of days only. And I do override the new beta version each time and I can switch to my real profiles to check stuff arround and quickly go back to normal.

2 Likes

actual set-up in the laptop:


2 Likes

just tested MIA on 2.1.26, it works.
you won’t be able to install the add-on using the add-on code.
you’ll have to manually download the files from add-on’s github page and move the src folder to your add-on’s folder.

2 Likes

I have just downloaded an add on to print my Anki cards. However, I get this message. Please help - Thanks!

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools>Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-ons section of our support site.
Debug info:
Anki 2.1.15 (442df9d6) Python 3.6.7 Qt 5.12.1 PyQt 5.11.3
Platform: Mac 10.13.6
Flags: frz=True ao=True sv=1
Add-ons possibly involved: Basic Printing Support

Caught exception:
File “/Users/pearlhayward/Library/Application Support/Anki2/addons21/1025789669/init.py”, line 57, in onPrint
qatxt = qatxt = c._getQA(True, False)[‘a’]
<class ‘AttributeError’>: ‘Card’ object has no attribute ‘render_output’

1 Like

That error message is strange. Did you perhaps move from a newer version of Anki to an older one? If you are able to upgrade, I imagine it will resolve the issue.

I have tried that, and unfortunately has not worked!

Please update to 2.1.26, ensure all add-ons are updated in the add-ons screen, and then if problems continue, paste the latest error message you’re getting in full.

Thank you for your reply. I have updated Anki and the add ons - and it is still not working. This is what comes up (even after trying to open my collection file and restarting my computer etc as it tells me to do below). Thank you!

Anki was unable to open your collection file. If problems persist after restarting your computer, please use the Open Backup button in the profile manager.

Debug info:
Traceback (most recent call last):
File “aqt/main.py”, line 340, in loadCollection
File “aqt/main.py”, line 365, in _loadCollection
File “anki/storage.py”, line 40, in Collection
File “anki/collection.py”, line 68, in init
File “anki/collection.py”, line 144, in load
File “json/init.py”, line 354, in loads
File “json/decoder.py”, line 339, in decode
File “json/decoder.py”, line 357, in raw_decode
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

see Unable to open Anki
and json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0) - #11 by Eldana

After using the latest version, if you wish to open your collection with an earlier Anki release, please go to the File>Switch Profile menu item, and click on “Downgrade & Quit”. If you skip this step, you may get an error message when opening your collection in an older Anki version, and you will need to return to this version, downgrade, then try again.

1 Like

Sorted - thank you so much!!

2 posts were split to a new topic: Main area is blank