Issue with ":" in field name of template

Greetings,

I have and older deck that I started going over again, but I noticed there was an issue with one of the notes.

I see this error:

Front template has a problem:
Found '<U+2068>{{Mnemonic for: (Use Kanji if needed)}}<U+2069>', but there is no field called '<U+2068> (Use Kanji if needed)<U+2069>'

Here is my whole front template

<div style='font-family: Arial; font-size: 60px;'>{{Mnemonic for: (Use Kanji if needed)}}</div>
<div style='font-family: Arial; font-size: 10px;color:grey'>(Mnemonic Picture, Pronunciation)</div>

Seems to me like its an issue with the colon in the field name. I tried changing it in the template, or in the note, but I cant save in either of those because of this error.

So I was wondering if there is some way to negate the colon here, or if there is a power tool I need to use to change the card template and field at the same time.

Thanks!

When you say “in the note” – do you mean renaming it the Fields manager – Adding/Editing - Anki Manual? If so, what sort of error are you getting then?

What if you start by cutting that field-replacement from your templates (and save the text somewhere handy)? Then will it let you rename the field to something without special characters? If that works, then you can paste that field replacement back into the templates and fix it to the new field name.

2 Likes

Yes, in the Fields manager I try to rename the field with the issue, or create a temporary field to swap the template to, but in both cases I get the error:
Card template ⁨1⁩ in notetype ‘⁨2. Japanese Mnemonics (With Kanji)⁩’ has a problem.
See the preview for more information.

This worked. I had to swap out all of the sides for all of the templates, but after I saved I could rename the field name in the Fields manager and swap back the old templates with the new field name. Thanks!

1 Like