iOS & iPad: Sync failure with filtered decks

Since we wrote, I tried to narrow it down also. But I can’t figure out any specific action that could be triggering it. (Filtered decks are synced fine with the latest update)
Sometimes I can study few cards in a filtered deck and still am able to sync. Then after another few cards I’ll get this error message. Happens across multiple filtered decks - so different search & filter parameter.
Thank you for taking the time and trying to reproduce it :slight_smile:

I have exactly the same situation.
Will try to figure out any special factors

Unfortunately it happens all the time for me but no special signs. The only thing is that I didn’t finish filtered deck at once but I did this in separate study sessions.

Is it limited to filtered decks with rescheduling disabled, or does it happen when rescheduling is on as well? Do you both use the v2 scheduler? Could it be a specific kind of card (such as one in learning, one that’s overdue, etc) that is connected?

In my case all my filtered decks have disabled rescheduling. I use schedule v2.
The problem came with last big update.

Today I got the same issue with desktop version (2.1.30) on windows

I’ve gone back and forth between desktop and mobile about ten times, answering some cards in such a filtered deck and then syncing, but have not been able to reproduce the problem, so I will need you to narrow it down some more for me - perhaps it’s related to the type of card you’re answering? If you sync more frequently does that seem to make a difference?

I did notice that AnkiMobile does not appear to be showing the correct buttons when rescheduling is disabled, and will look into that.

Thanks again for helping us out!
I’m a week away from a really important state exam, so it’ll be hard for me to focus on narrowing the error down. I give it my best shot and will keep you posted if I’ll find anything…

I tried a few times and these steps allowed me to reproduce the issue every time I tried. Rebuild the filter deck.
Start studying.
After few cards shake the phone to undo the last answer and do not answer this card again. The last performed operation is undone answer.
Close the deck and try to sync.

Thanks, that sounds promising - I’ll give it another try.

I had the same issue when studied regular not filtered deck. Now I am confused.

Basically since last update I have used full sync a few times a day.

I’m also on the 20065.3 iOS beta and get this error at least once a day. Running the repair tool doesn’t seem to have any effect and I need to run a full sync. I’m on 2.1.30 on my computer but the mobile problems happen even if I’m not using the desktop version for days. I’ve tried running through a bunch of scenarios to trigger the error. What I found did it for me was reviewing forgotten cards, then selecting undo on a card. That forces me to do a full sync to clear the error.

When I used ctrl+z I got the same error on the desktop app.

Ok, I’ve finally reproduced it - it does not appear to be related to the type of card; it seems to be caused by syncing and then undoing a review that you did prior to the sync, which Anki should not be letting you do. Thanks for the report, I’ll fix this in the next update.


For me, the issue only appears when I’m undoing a review in the middle of reviewing forgotten cards. If I’m reviewing the day’s cards for the first time, I can undo in the middle and when I sync later, I get no issues. But if I review forgotten cards again later in the day and undo in the middle of that, I’ll get an error and need to do a full sync. Does that fit what you mean by undoing a review that I did prior to the sync (i.e., do daily review, sync, review forgotten, undo, sync -> error)?

There may be more than one issue going on here. I’ll have a fix for the undo queue not being cleared on sync in the next beta; when it’s posted on the beta testing section, please give it a try and let me know if your issue persists or not.

How can I become a beta tester?

Just tried 20066.1 and am still getting the same sync error when I review forgotten cards and have an undo during a review.

@jam9 Thanks for trying. I still can’t seem to reproduce it by answering a card, undoing, syncing, and repeating that a few times. Any other info you can provide on the steps that seem to trigger it would be appreciated.


For me, it’s not causing a problem when I do the scheduled review for the day. It’s only happening when I complete that and then do a custom review selecting review forgotten cards. If I have any undo during the review of forgotten cards, then I get an error the next time I try to sync. This happens even if I just review today’s forgotten cards without a lookback to prior days. The check database function does not clear the error. Only a full sync seems to do the trick.