Invalid weights provided

Hello, today I encountered an issue with anki. Suddenly an error message appeared and the application stopped working, after restarting anki and trying to start studying again, the same message appeared. (picture below)

I tried all the troubleshooting recommendations several times, restarting the computer, checking the database, checking the add-ons (I tried with no add-ons activated, and the issue remained) and I also reset thePreformatted text window sizes and the video drivers.

After, I tried restoring to a backup from earlier today, and it seemed to be working, after around 15 minutes the same error appeared again. This is the debug code:

Anki 24.04 (429bc9e1) (ao)

Python 3.9.18 Qt 6.6.2 PyQt 6.6.1

Platform: macOS-14.2.1-x86_64-i386-64bit

Traceback (most recent call last):

File "aqt.taskman", line 142, in _on_closures_pending

File "aqt.taskman", line 86, in <lambda>

File "aqt.taskman", line 106, in wrapped_done

File "aqt.operations", line 127, in wrapped_done

File "aqt.reviewer", line 538, in after_answer

File "aqt.reviewer", line 551, in _after_answering

File "aqt.reviewer", line 241, in nextCard

File "aqt.reviewer", line 257, in _get_next_v3_card

File "anki.scheduler.v3", line 55, in get_queued_cards

File "anki._backend_generated", line 687, in get_queued_cards

File "anki._backend", line 173, in _run_command

anki.errors.InvalidInput: invalid weights provided

===Add-ons (active)===

(add-on provided name [Add-on folder, installed at, version, is config changed])

Advanced Review Bottom Bar ['1136455830', 2024-02-04T19:38, 'None', mod]

Anki Simulator ['817108664', 2023-11-06T18:26, 'None', '']

Deadline2 ['723639202', 2024-02-26T04:38, 'None', mod]

Enhance main window ['877182321', 2023-10-22T22:28, 'None', mod]

FSRS4Anki Helper ['759844606', 2024-04-26T19:38, 'None', mod]

Progress bar Fixed for Anki 24 by Shige ['1708250053', 2024-04-23T03:42, 'None', mod]

Review Heatmap ['1771074083', 2022-06-30T03:43, 'None', '']

Review Lookup ['1745211643', 2022-06-22T09:12, 'None', '']

===IDs of active AnkiWeb add-ons===

1136455830 1708250053 1745211643 1771074083 723639202 759844606 817108664 877182321

===Add-ons (inactive)===

(add-on provided name [Add-on folder, installed at, version, is config changed])

Don’t really know what to do next, so I’m posting this here hoping someone can help.

That error sounds like it’s coming from FSRS. Are you using the default parameters, or personally optimized parameters?

1 Like

You should be able to fix it by opening your deck options, and resetting the parameters to the default, or optimizing again.

1 Like

I was using the default parameter, although after resetting every configuration it started working. Thank you

1 Like