Anki Forums

Images Showing As White Boxes

There has already been posts asking about why the images are not showing, regardless if they are jpeg, png, etc, and the only answer that was given was to make sure that the syncing is completed and done on both devices. I have synced on each device several times, and that doesn’t seem to be the issue. If anybody could please help, I will definitely changed my rating on this app to 5 stars. I included an image of what it looks like on my screen below.

Do the images show on Anki on the desktop? Or are they also displayed as boxes?

You have some images that have very long filenames. Using the Check Media option in the preferences screen should allow those to display. If you continue to have problems after that, do the same cards appear correctly in the computer version? And if so, do they when studying with AnkiWeb?

I think I just found the solution to my problem. The media files would not show on my phone but they did on my computer. However, today I went to preferences on anki on my computer and I turned on the “paste clipboard images as png” and it started to show.

I suspect that may have been coincidental, and would recommend you use Check Media if you have not already done so. Glad to hear things are working now in any case :slight_smile:

I’m so sorry, but the white boxes started appearing again. I did what you and went to Check Media and it shows many unused files. What do I do with them to make them show? The only action is to delete them, and I don’t want to do that.

“Missing files: 0” is saying that you’re not missing any files, so it is strange that you would be seeing boxes. If you’re still having issues after using Check Media, is it only the most recently added cards you’re having trouble with? If so, this is likely caused by you using an old version of Anki on the computer. Older versions did not limit the filename length, so ‘check media’ is required to fix things up. If you update Anki and run check media once more, you should not need to do so again.