Image Occlusion Enhanced [Official Support Thread]

@dae @krmanik replied on the PR just now (as I think that moving the discussion there is going to make it easier to discuss further changes)

3 Likes

Thank you very much. I have added my reply and will consider the suggestions for better and improved Image Occlusion feature for Anki Ecosystem.

1 Like

Same problem here! Were you able to solve it?

After updating anki my image occlusion add-on has stopped working as I can no longer add images to my anki cards. Do I need to update the add-on for it to work again? If so how do I update it?

@HenZen

Try reinstalling the add-on from here: Image Occlusion Enhanced - AnkiWeb

@KELQC This usually appears when using the custom path tool and/or the pencil tool. I would recommend using rectangles and simple lines for now. The upcoming IOE update will handle issues like this a bit more gracefully with a much more informational warning message (but still basically recommending not using some of the more finicky tools for now).

This may be a general issue since it basically happened for me on Windows 10 (but without any error messages). Started with a fresh install of Anki & only IOE as an add-on. Opened up an issue on the Github tracker

#264: Anki fails to open when Image Occlusion Enhanced is enabled on Windows”

with more details. (I would’ve provided a direct link, but Discourse isn’t letting me put links likely because this is my first post on the Anki Discourse forum.)

Oh yeah, and for clarity, when I said “This may be a general issue”, I was referring to the posts by @kbee (post 52 on May 3, 2022) and @KELQC (post 59 on Sep 25, 2022).

Hey, I’ve got the following problem: at first I can add images to my flashcards but then, in the preview as well as on the actual card it tells me that the front is supposedly empty/blank (it shows neither the image nor the masks or the text, it just says “the front of this card is blank”…). I’ve tried it with both V.2.1.54 (Qt5&6) and V.2.1.49. Thanks a lot already :slight_smile

My Anki is currently running on Mac V.2.1.54 Qt5

Hi there, looks like someone else opened an issue for this in Aug 2020. I apparently haven’t used this forum enough to be given permission to post links, but if you Google the following string:

The front of this card is blank #164 github

Then you should find a link to github > image-occlusion-enhanced > 164.

EDIT: My permissions just changed. Here’s the link

The same person who opened the issue also closed the issue without comment, but maybe you could ask them what they did?

Alternatively, you can try these steps to see if they fix the issue: When problems occur - Frequently Asked Questions

1 Like

Hey @glutanimate, just a heads up that your link to “my quick tutorial here” is dead.

1 Like

@Philogicatician Thanks for letting me know! @dae it looks like the OP is too old to be edited. Is that something you can unlock on a case-by-case basis? With evergreen support threads like this, it would be handy if they remained editable, so that authors can e.g. update key info and FAQs.

I don’t think I have individual control over this, though as a workaround you could convert the post into a wiki post, and then you (or others) would be able to edit it. If you want to do that and don’t have permission to do so yourself, please let me know.

Hi I am just wondering if it is possible to be able to add multiple images to one image occlusion card?

Hi,
I started using IOE 1 month ago,
When I create a card, there is a black outline around the image.
Is there any way to remove it so that the card can be uniform ?

Thank you for tany help that you can give !

Hey @glutanimate :smile:
Thank you for developing such a life saving add-on.
Anki wouldn’t feel complete without it. It’s quite convenient and time-saving.
There’s just one thing that’s really annoying: the toggle mask button doesn’t seem to be working. I’ve tried it on multiple devices, deleted and reinstalled, started anki in safe mode, disabled all other addons, yet nothing seems to be working.
Your help would be truly appreciated!
Thank you <3

i too have received the same error . did you solve urs ?

I hope this is the correct place to ask a question.
I really love using this add-on, it’s made my studying so much easier.

When I use Image Occlusion, I would like to put a hyperlink in (anywhere) when I create the cards. In the Fields location for source, I am able to paste a website address, but not the link.

I also see the hyperlink button above but that doesn’t seem to work- I paste a link in but it doesn’t show up. I can, however, go back and study the card, then edit the card and use the hyperlink add-on.

I would like to add a hyperlink when creating cards and not have to go back and edit. Thanks for any help or clarification.

Hi @kevtech, unfortunately there’s no easy way to do this at the moment, given that the entry fields in IO’s window only support plain text. Besides going back to the notes after creating them, the only other option would be to paste the link into Anki’s regular “Add Cards” screen, switch to the HTML view for the field, and then copy and paste the HTML code into the respective field in the IO window.

I.e., you can use HTML syntax to introduce links (e.g. <a href="https://google.com></a>", and to avoid having to type the syntax manually, you could copy and paste it from Anki’s window after using the hyperlink add-on there.

Thanks for the kind words, and sorry to hear that you’re having trouble with the toggle mask button. It seems to be working locally for me still, but sometimes features like this that are encoded into the card template can be broken either by other add-ons, or by accidental modifications to the template itself. So my recommendation would be to try two things:

  1. Restoring the IOE template to its default state by following the steps here: Troubleshooting · glutanimate/image-occlusion-enhanced Wiki · GitHub
  2. Disabling all add-ons other than IOE and seeing if that fixes things.

Hope that helps for now.