How do I disable that Anki interprets html tags in questions?

Hello to the forum!

I just started with anki some days ago and use it mainly to memorize html, css and java script related knowledge.

Now I have run into a problem.

In my anki card I want to write text with html tags in the text of my question and don’t want anki to interpret this tags so that it shows the text formatted. Instead the text should be displayed not formatted with the tags displayed inside the text.

For example the question should be:

We have an html element < h2>Flowers</ h2>
Change the html code in a way that the font-size for this element is 20px.

Answer should be:

< h2 style=“font-size: 20px;”>Flowers</ h2>

Even here in the forum a had to insert a space inside the tags so that they are displayed and not interpreted.

Can I turn off html tag interpretation?

Thanks for your help in advance.

Niels from Germany

There’s an option in the importing screen.

You can escape characters that you don’t want to be interpreted in HTML with the form &...;, replacing the ... either by a numerical identifier of the character, or (often) a mnemonic name. For instance, tag boundaries can be escaped with &gt; and &lt; (greater than and less than), which, for example, allows me to write <h2>Flowers</h2> with &lt;h2&gt;Flowers&lt;/h2&gt;.

Also note that, in this forum, you can escape Markdown formatting with backticks (`).

1 Like