Help Opening Anki?

Hi all, I just downloaded Anki-2.1.38 and updated my Anki application with it on my Mac laptop. Right before updating, Anki was working fine for me, but now I click the application and it just tries to open for forever before ultimately saying “application not responding”. Tried uninstalling and even deleting my Anki folders, restarting the laptop, and then reinstalling Anki but that didn’t work either.

I also went to Terminal and tried opening it from there, same result with the app not opening. But when I went to Console and tried opening the app, these messages showed up: “-[ADCloudKitManager _setupVTZoneFetchCompletionBlock:] Zone fetch completion is non nil”

“Couldn’t read values in CFPrefsPlistSource<0x7fed1360a9b0> (Domain: kCFPreferencesAnyApplication, User: kCFPreferencesCurrentUser, ByHost: Yes, Container: (null), Contents Need Refresh: No): accessing preferences outside an application’s container requires user-preference-read or file-read-data sandbox access”

Thanks again for your help! Not really sure what to do from here. I have a Macbook Air that is on macOS Catalina if that makes a difference!

Those messages don’t look related to Anki. If restarting your machine does not help, there’s a link to an older Anki version on the download site - if you switch back to that version, how do you go?

A google search brings up this link, which suggests:

I quite the app and then used ActivityMonitor and ‘ForceQuit’ the ‘root’ instance and the instance running on the user account.

Re-ran the app and no more of the errors described above. Cool

Hi Dae! Thanks for asking, I forgot to mention that I tried using the 2.1.35 version (the older one on the website) with all the steps I described above too! :frowning: And about the messages, I’m not too sure how to read/interpret console/terminal messages yet, so I’m sure you’re right!

Hi! I was able to ForceQuit the Anki itself, but unsure what the “root” instance is… Could you explain more that is/how I should find it to forcequit it? I know that there are users, of which one is named “root”.

I think Henrik means “top-level Anki process” when referring to the root process. If restarting your computer did not help, it may be worth trying to run Anki from a terminal. Assuming it’s in your /Applications folder, please open and run


If you’re not on the latest version, AnkiMac might be Anki.

When you do that, what text is printed?

Hi Dae,
I ran Anki on using “open -a Anki” as well as “/Applications/”. Both options give me no text printout on Terminal, but “open -a Anki” gives me the bouncing Anki icon appearing (no text printout appears either when it stops bouncing). The only other thing that changes is that the title of the whole Terminal window changes from “-bash” to “Anki”. I’m sorry that this isn’t very helpful…I really wish this would work too! Thanks so much for continuing to help troubleshoot.

You could try rename your data folder to see if that helps.

Hi all!! The problem is solved, it was some other application on my laptop that was behaving weirdly, so deleting it made Anki open normally! Thanks so much for your help and patience.

Glad to hear it’s resolved. For the benefit of others who may be having the same issue, what was the app?

It was the HP Device app! Specifically the HP Device Monitoring.framework issue that many Mac users have been having to deal with since the update made it incompatible and recognized as malware.

1 Like