Headers when importing from excel/numbers

Hi, when importing cards with csv files using headers which set the settings for the import like explained here is very useful. I am trying to add these headers into excel or apple numbers directly, but did not find a way how to include these headers so the anki program recognises them. Does anyone know where to write those headers?

This is how the cards might look like in Apple Numbers.

Here are the exact headers i am trying to add, which work when you add them to a csv file:
#notetype: Basic

Export one of your decks in the format.txt with these headers and see how anki does it.

1 Like

Hi thanks for the reply. Just tried it. Unfortunately there is no such option for me to export my decks as .txt nor .csv only as .apkg.


#guid column:1				
#notetype column:2				
#deck column:3				
#tags column:6				
Lg!RP4KU:n	nametype	NameDeck	123	321
l4(@R*%cs;	nametype	NameDeck	124	421

I added the headers like you.

But it seems to not affect the import settings. :frowning:

Have you tried looking at your csv file in a text editor (not a spreadsheet program) to see whether it is being output correctly? I’m not familiar with Apple Sheets, but I can’t help but notice that it’s treating row1 and column1 differently than the rest of the sheet.

I also see that your header specifies Pipe as the separator – is that the actual separator that the file is using?

this is what the csv file looks like.

I have no idea how to fix it, maybe ill need to try to do it with excel.

Problems include –

  • Your spreadsheet said the separator was pipe, but this file clearly has a semicolon separator (and is missing the separator header anyway …).
  • This file thinks you have lots of empty columns/fields for every line - including the header lines.

What you really need is not from Excel or Sheets – it’s just the text/csv file. I think if you go back to the instructions (Text Files - Anki Manual), and make your text file comply with the rules, you’ll be able to import it just fine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.