Going backward in learning steps instead of graduating [Intervals changed without changing settings]

Hi everyone! I’m having a little issue here. My intervals for my “learning cards” have been the same for the past year and a half and they just all of a sudden changed without me touching the settings.
Here are how the intervals normally are (starting new card):
New: 25m, 12h, 1d, xd

If I click “good” (1d), the intervals the following day are always:
25m, 1d, 3d, xd

However, today when I started doing them these cards have intervals as if they’re new even though I’ve been seeing them for days:
25m, 12h, 1d, xd

Does anyone have any advice? For some reason some of my cards are showing the way I like and some have changed. I’m quite frustrated. Thank you!

Can you post the Card Info (Statistics - Anki Manual) for a card (or 2) that had the “New” intervals, even though it wasn’t new?

Do you sync your collection between different devices? Are you consistent in making sure you sync at the beginning and end on every device?

I’m not sure if this helps (if it does, great. If it doesn’t, please disregard). But the same card that I saw the “new” intervals on 6 hours ago now has switched the “hard” interval to 1d because I am within 12 hours of my next day starting (I have it set for 1 am). I figured this out according to this:

So now the “new” interval on the card that isn’t actually new looks like this:

When for the past year and a half until this morning it would look like this no matter what time of the day:

I’m wondering if there is an add-on update or software update that messed things up? I’ve been clicking buttons one way for a year and a half and I really don’t want to have to mess with my intervals and figure something new out again.

If it’s helpful I can write down how I normally go about choosing which button I hit for learning cards (again, hard, good, easy)

That advice looks familiar! :wink:

An add-on is definitely a consideration, and if you haven’t already tried this – run Anki with add-ons disabled (hold down Shift while opening), and see if the same thing is happening.

Have you updated Anki recently? Especially from the v2 to v3 scheduler, or from the SM-2 to FSRS algorithm?

Nothing looks amiss on that Card Info. (And I’m not sure if the images of answer buttons go wtih that one, or are from other ones.) Do you have Card Info where the card was actually given an incorrect interval?

Are you sure that all of your decks (including sub and parent decks) are using the same preset, with the same steps and options?

I just tried without add-ons and the same problem happened. I haven’t updated Anki recently. I’ve been running V3 scheduler for a while and actually just went and tried to switch back to V2 and can’t find the setting. I read online maybe a newer version of Anki has made it so you don’t have the option anymore and you have to use V3? I haven’t switched to FSRS because I just haven’t had time to look into it.
With regards to the settings, yes, I make sure to save to all subdecks. I just have “default” that includes all of my decks

Let me see if this helps you at all:
First time I see a card my intervals are 25m 12h 1d Xd. I always click 1d (good) because I don’t have the time to go through up to 100 cards a day multiple times at 25 minute intervals until I know it. So I click 1d and basically skip that first learning step and just get the card into rotation and pushed to the next day.

The next day when I see that card my intervals have always been 25m 1d 3d Xd (for my second learning step). I click 3d (good) if I know it and 1d (hard) if I don’t for the same reason above (seeing that many cards every 25m is not something I have time for).
This is where I’m running into issues. All of my cards in the second learning phase that should be showing 25m 1d 3d Xd are now acting as though I’m still on the first learning phase and show me first learning phase intervals (25m 12h 1d Xd) as if I haven’t already passed that phase yet.

Correct, support for v2 has been removed.

Thanks for trying/checking those things. And I appreciate you describing your process more fully. It’s unique, but it explains why this has been so apparent to you, and so disruptive to your cycle.

Your description matches what I was understanding from you so far – I’m just trying to figure out if there’s a reason this is happening. Looking at Card Info that shows the error is often the quickest path to that. For instance, it could eliminate this being a display issue – where the interval shown on the button doesn’t match what was applied to the card; it could eliminate this being a mistaken-identity issue – where (no disrespect intended, just exploring all options) you might be confusing one card with another; etc.

I agree with you that with 25m 1d 3d steps, when the card is on the 1d step, Again should be 25m (back to first step), Hard should be 1d (repeat current step), Good should be 3d (next step). So what I’m looking for is an example of a card that definitely did not behave that way.

Okay what can I do to help? Send more screenshots of card info?
When I change interval step 2 in my settings it adjusts what I see, so I don’t think it is a display issue.
And I’m not sure 100% what a mistaken-identity issue is, but I think it means maybe I’m thinking a card has been through its first learning step but actually hasn’t? If that is the case, then no disrespect taken at all haha. That’s definitely something that could occur, but it’s never happened once in a year and a half. Originally I thought this weird interval stuff was only on cards I unsuspended yesterday, but it is happening on cards that I have been unsuspended for a week that I have been pressing hard on because I just can’t remember them yet.

Once we get this problem figured out I would love to chat about how you prefer to click various intervals and when. Your strategy. I’ve never really been taught so I’ve just been doing what works for me.

I will start taking more screenshots of card info just in case that is what you need. I look forward to hearing from you! Thank you!

This is a good example. I am still seeing my second learning step interval options for this card even though I have clicked “good” twice and should be seeing the third learning step. It is like my cards aren’t graduating learning steps

On the second learning step I always saw 25m 1d 3d Xd now I’m seeing 25m 12h 1d Xd. And on the third learning step I used to see 25m 3d 5d (graduating interval) and now I’m seeing 25m 12h 1d Xd. It’s like it is stuck on that first learning step almost. Is that possible?

In this one, you clicked Good, it advanced to the 1d step, you clicked good, it advanced to the 3d step, and it’s due 3d later. That’s expected behavior, isn’t it?

Or are you saying that even thought this one recorded the correct events, this isn’t what was displayed on the buttons in the reviewer?

Getting stuck on a step generally isn’t possible, no. That’s what’s weird!

I’m happy to tell you. I know that recreational-what language-learners (like me) do, and what med-school-anking folks (like you) do, are not necessarily aligned! :sweat_smile: But there are some overarching things that apply to everyone.

And you’re right that we can put a pin in this for later, but the thought I don’t want to forget is – using anything besides Again for an answer you got wrong is a bad habit. [It will also make it impossible for you to transition to FSRS at some point in the future (even though you haven’t read up on it yet, it’s pretty great, and you’ll probably want to switch at some point).] It leaves me wondering if there’s a set of learning steps and options that would be a better fit for how you want to use the system.

The first time I clicked good (1 day). The second time I hit good I hit 3 days. In a normal situation, the next time I saw the card, my intervals would be 25m, 3d, 5d, Xd (as my third learning step into my graduated interval). However, today instead of that normal 3rd set of intervals it showed 25m, 12h, 1d, Xd (similar to what I normally see on a brand new card and what I saw two “good” clicks ago on this very card). Does that make sense or am I not getting it across well?

Yes I would love to chat strategy soon. Maybe altering my intervals so “again” is 1 day would work better for me. And learn about FSRS at some point

1 Like

I hear what you’re saying – the intervals on the grading buttons are not what you expect based on the current state/step of the card.

Here’s what I would recommmend next –

  • During your study session, get to a Learn card with a button showing an incorrect interval
  • Grade the card using the button with the incorrect interval
  • Then immediately open More > Previous Card Info and take a screenshot
  • [We’re not going to break your collection! Go back to the study window and Ctrl Z to undo that grade. Then you can continue studying as usual.]

Get a few of those screenshots together, and let’s see what’s actually happening to the cards.

@dae Is there a way to bump @Dsvarney99 up a level so they can post again and add their new batch of screenshots here? :crossed_fingers:t4: :pray:t4:

I’ve bumped the limit on replies for users in their first 24 hours.

1 Like

^^^Current cards. That most recent “3” rating should be 4 or 5 days at the graduated interval and instead it is at 1 which is the “good” interval I’m currently seeing that’s the issue.

What my older, normal cards all look like when they first started out^^^

This is another good example. Based on how I normally do my cards (which needs to be fixed haha that’s another story) these intervals should be 25m 3d 5d Xd but instead they’re as seen. So if I click “good” instead of going to 5 days out like it normally would it only goes to the next day as if it is my first learning interval (because that’s what I have in my settings for learning intervals (25m again, 1d first interval, 3d second interval, 5d graduated interval)).

This one should have a “good” interval of 3 days but it is 1. And when I go back and look at previous card info it in fact only does 1 day:

I hope this is what you were looking for

Yes, this is exactly what I was looking for!

Those cards are definitely staying in Learn as well (not graduating to review) – because there’s no initial Ease set.

Someone smarter than me is going to have to take a look at this. Maybe there’s a rational explanation, but I’m not coming up with anything!

In the meantime –

  • Have you done a “Check Database” lately? Give that a try.
  • What version are you using? [Help > About > Copy Debug Info, and paste that whole thing here.]