`GLIBC_2.28' not found

Cannot run either Qt5 or Qt6 latest builds (2.1.53) on Ubuntu 20.04 with the following error when running anki:

Anki starting...
Initial setup...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "aqt", line 39, in <module>
  File "anki.lang", line 12, in <module>
  File "anki._backend", line 39, in <module>
ImportError: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /home/USER/Downloads/anki-2.1.53-linux-qt5/lib/anki/_backend/rsbridge.so)

Tried updating apt but the latest version of libc6 appears to be 2.27-3ubuntu1.6. Are you building these on 22.04 where this package might be newer? Any chance to set up CI for building different distros on github? I can try to build on my own, but I’m guessing there are still a fair number of people on 20.04.

First of all, debian-based distributions are not know for being particularly in a hurry packaging the latest version of softwares, quite the opposite actually, the idea being that the more you wait before packaging the next version of a software, the more you can be sure that you have skipped the versions that are more buggy or contain critical vulnerability.

lol… Anki is, currently, not even packaged for different distros (the only distro that achieved that is Arch), let alone having a CI for these packages.

The binary builds have a minimum glibc version of 2.28, as that is the minimum supported by the graphics toolkit. Some Googling seems to indicate that Ubuntu 20.04 uses 2.31 and thus should work fine - it sounds like you are on the older Ubuntu 18.04, which is a bit too old for recent Anki releases.

1 Like