Flatpak crashes due to QtWebEngineProcess failing

Hi Guys,

first of all thanks for this awesome project.

Im trying out the new Asahi Fedora Remix on M1 Mac and want to install Anki. There are no repositories and I have no clue how to use qemu so I tried the Flatpak net.ankiweb.Anki which seems to be the most recent opens the language selector just fine, but then crashes with the cryptic QtWebEngineProcess quit unexpectedly. Looking in to the Log files I just see QtWebEngineProcess killed by SIGTRAP%.

Id be glad if anyone could help!

Flatpak does not have an up-to-date version for ARM, you can try installing via python , docs here

Anki on aarch64 is terribly out of date · Issue #125 · flathub/net.ankiweb.Anki · GitHub

Anki outdated version · Issue #93 · flathub/net.ankiweb.Anki · GitHub

There seems to be an attempt for building an arm build from Alpine Linux, if you would like to try it out and report bugs

You are welcome to continue using your distro’s version of Anki if you prefer, but if you run into any issues, you will need to report them to your distribution’s package maintainers.
Linux Distro Packages - Anki Manual

If QtWebEngine is not working in Fedora Remix, this is something you’ll need to report to your distro’s maintainers, preferably after reproducing it with another QtWebEngine-using app like qutebrowser.

Thanks for your hint. I installed qutebrowser but it worked without a Problem :confused:

Sorry, I wasn’t clear. Such a test is only useful if you’re running Anki and qutebrowser from Python as described in Intro & Downloads - Anki Betas. If you’re using Flatpaks, you’re only testing the Flatpak and not the system Qt. Please note the Flatpak is maintained by a third-party, so if you wish to continue using it, you’ll need to report any issues with it to the Flatpak package author.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.