Flag Icon Does Not Show Up

This has been frusturating me for a couple weeks now. The flag icons on my cards show up as a square box on Windows 10 Desktop App.
Like this:

It doesn’t happen on all my computers, just my HP Spectre running the most recent (2021-09-08 20:31 Windows 10).

I have followed the instructions here When problems occur - Frequently Asked Questions

Other things I’ve tried

  • I have tried all the video drivers
  • I have tried reinstalling
  • I have tried reinstalling, restarting, and installing.
  • I have tried uninstalling with BCUninstaller (which removed all remnants and registry keys)

However I still can’t see the flags on my laptop. I searched here but could not find solutions or anyone else with this problem.

I am on Version ⁨2.1.47 (dc156f34)⁩
Python 3.8.6 Qt 5.14.2 PyQt 5.14.2 however this has persisted through several versions

The flag is a unicode flag symbol, so if it’s not showing up, that seems to point to an issue with the default font on that system.

This seems right, thanks! Its really weird that it works on my desktop but not my laptop. So I went and changed the default font to Banschrift which does have U2691 but the square is still showing up (i.e. no flag). Is there something I need to reset in windows?

Anki should be using “segoe ui” on Windows - maybe that font is missing?

Well the font exists on Windows, but my windows UI font is different, (i.e. not segoe). is there a way to force Anki to use segoe as it’s on the system? or is this a bug? this would be an accessibility issue for people who use dyslexic fonts as system default for example.

I’m not sure what’s going on here. Anki hard-codes the font in its webviews to Segoe UI, so if you’ve selected a different default font, it should still be using Segoe UI.

1 Like

The default font can be updated on windows via winaerotweaker or similar, which updates the registry keys. For disabled folks it is quite common to update UI fonts via these methods.

I definitely have Segoe UI on my laptop, yet Anki is not pulling it—I think its pulling from a font w/o the flags, or there is a setting wrong somewhere. I have tried removing and reinstalling anki, and I can try to reinstall the font but I suspect that there is not a way to force anki to re-read for the font. I’m not sure what’s happening either.

How do the registry entries work? Are they telling Windows to use a different font, or to substitute a font instead of “Segoe UI”?

here’s how it works:

i replied to you with links to winaero, but askimet blocked the URL Go to winaero dot com and add the following after the dot com /change-system-font-windows-10/

Hi @brimwats,

The flag character is not actually rendered in Segoe UI font, but in Segoe UI Symbol font. I think it’s a mechanism called font fallback or font linking, but I’m not sure which term is correct.

I think the cause of the problem is that the tool you are using to replace the system font is rewriting not only Segoe UI but also the registry entry for Segoe UI Symbol.

Here is the corresponding part of the registry for the two fonts

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"Segoe UI (TrueType)"="segoeui.ttf"
"Segoe UI Symbol (TrueType)"="seguisym.ttf"

If you replace "Segoe UI (TrueType)" with a different font, there will probably be no problem. However, if you replace "Segoe UI Symbol (TrueType)" with a different font, symbols will not be rendered unless the font has the characters for the symbols.

Screencast (gif):



thanks so much! I can confirm that this is the issue. I pinged the winaero folks on twitter, hopefully it’s addressed!

1 Like