Error when clicking the Options button

Hello Anki community! I am having some issues using Anki from a desktop with Linux operating system. The specific issue I’m seeing is within the main screen where it has a list of your decks, clicking the gear icon for a deck and clicking Options gave me this error. I have included the error info below:
Anki 2.1.15 (442df9d6) Python 3.10.6 Qt 5.15.3 PyQt 5.15.6
Platform: Linux
Flags: frz=False ao=False sv=1

Caught exception:
File “/usr/share/anki/aqt/”, line 213, in
a.triggered.connect(lambda b, did=did: self._options(did))
File “/usr/share/anki/aqt/”, line 242, in _options
File “/usr/share/anki/aqt/”, line 869, in onDeckConf
aqt.deckconf.DeckConf(self, deck)
File “/usr/share/anki/aqt/”, line 25, in init
File “/usr/share/anki/aqt/”, line 49, in setupConfs
File “/usr/share/anki/aqt/”, line 66, in loadConfs
File “/usr/share/anki/aqt/”, line 89, in onConfChange
File “/usr/share/anki/aqt/”, line 175, in loadConf
<class ‘TypeError’>: setValue(self, int): argument 1 has unexpected type ‘float’

I have tried clicking Tools > Check Database, restarting Anki and desktop, neither worked. So far all other buttons seem to work fine. Please let me know if I’m missing or need to download any add-ons for this to work.

This is a known issue with this very old version. Please update to a new Anki version from the website.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.