Error message with image occlusion

I have been getting an error message with anki. When the message appears I am usually making an image occlusion card. The error message appears and then anki freezes and the only way for me to do anything is to force quit the app. I have already tried restarting my mac, deleting unnecessary add-ons, updating anki, checking anki database, force syncing in 1 direction, and deleting and re-installing my add-ons (I only have image occlusion and heat map). This is the message I recieve and the debug info:

Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.1.2-arm64-arm-64bit

Traceback (most recent call last):
File “aqt.taskman”, line 142, in _on_closures_pending
File “aqt.taskman”, line 86, in
File “aqt.taskman”, line 106, in wrapped_done
File “aqt.operations”, line 129, in wrapped_done
File “aqt.operations”, line 158, in on_op_finished
File “_aqt.hooks”, line 3840, in call
File “aqt.deckchooser”, line 120, in on_operation_did_execute
File “aqt.deckchooser”, line 82, in _update_button_label
RuntimeError: wrapped C/C++ object of type QPushButton has been deleted

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Image Occlusion Enhanced [‘1374772155’, 2022-04-09T03:15, ‘None’, ‘’]
Review Heatmap [‘1771074083’, 2022-06-29T21:43, ‘None’, ‘’]

===IDs of active AnkiWeb add-ons===
1374772155 1771074083

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

Help appreciated!

On the Image Occlusion Enhanced add-on page, someone reported this same error on 2023-11-11.

A note for the add-on’s author @glutanimate : the same error in a thread from a couple of years ago got this response from dae:

DeckChooser has a cleanup() method that should be called before you close the window containing it, or it will keep receiving messages even after it has been partially destroyed.

Thanks for your response. Where do I find cleanup/deck chooser to fix this issue? I’m confused on where to put cleanup()

I don’t know. I haven’t looked at the source code of this add-on, and I have no more information than the one paragraph that was quoted above.

It was mostly just intended as a heads-up for the add-on author in case he wasn’t aware of that older thread from two years ago. The add-on’s author could quickly take a look and assess if this potential fix is applicable.

1 Like

I sent a fix for this about two years ago, but no update was released since then:

1 Like

Thanks for the fix back then, @abdo. It’s definitely not great that this isn’t available on AnkiWeb, yet. IOE is in a weird transitional state at the moment, caught between native IO and ongoing development on the rewrite of the add-on.

I am planning on updating the listing soon with a (mostly) bug fix release. Until then, uninstalling the version you have currently installed and then installing the latest test release from GitHub should fix the issue you’ve been seeing @user1234.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.