Add-on isn't working

I am facing this error while using image occlusion enhanced add-on

Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.3.1-arm64-arm-64bit

Traceback (most recent call last):
File “aqt.webview”, line 628, in handler
File “/Users/shraddhapatel/Library/Application Support/Anki2/addons21/1374772155/”, line 324, in
lambda val, choice=choice, close=close: self._onAddNotesButton(
File “/Users/shraddhapatel/Library/Application Support/Anki2/addons21/1374772155/”, line 358, in _onAddNotesButton
File “aqt.main”, line 851, in reset
File “aqt.main”, line 803, in _synthesize_op_did_execute_from_reset
File “_aqt.hooks”, line 3840, in call
File “aqt.deckchooser”, line 120, in on_operation_did_execute
File “aqt.deckchooser”, line 82, in _update_button_label
RuntimeError: wrapped C/C++ object of type QPushButton has been deleted

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Advanced Browser [‘874215009’, 2023-10-21T20:04, ‘None’, ‘’]
Image Editor [‘307397307’, 2022-09-08T09:39, ‘None’, ‘’]
Image Occlusion Enhanced [‘1374772155’, 2022-04-09T12:45, ‘None’, ‘’]
Review Heatmap [‘1771074083’, 2022-06-30T07:13, ‘None’, ‘’]
True Retention [‘613684242’, 2017-11-20T02:13, ‘None’, ‘’]
extended editor for field for tables searchreplace [‘805891399’, 2023-07-31T19:42, ‘None’, mod]

===IDs of active AnkiWeb add-ons===
1374772155 1771074083 307397307 613684242 805891399 874215009

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

1 Like

Try reinstalling

This problem has dealt years ago, not sure why it is appearing back, hopefully reinstalling or add-on > check updates fixes it

thank you for reply . I reinstalled Anki’s latest version, deleted add-on and added it again, but still it’s showing same error every time when I tried to use it.

Problem have been reported and will be fixed soon


I installed it and my issue is fixed now. Thank you sir :saluting_face: