Error message with Forvo

Have tried to transfer Forvo pronunciation to my deck but have received error message: Anki 2.1.54 (b6a7760c) Python 3.9.7 Qt 5.14.1 PyQt 5.14.1

Platform: Mac 10.15.7

Flags: frz=True ao=False sv=2

Add-ons, last update check: 2023-03-16 10:29:44

Caught exception:

Traceback (most recent call last):

File “aqt.editor”, line 1221, in dropEvent

File “aqt.editor”, line 1250, in _processMime

IndexError: list index out of range
I have checked database, deleted all add-ons, etc.
I am using the latest Firefox browser on an imac desktop and it worked just fine earlier today. Any suggestions, please?

You forgot to mention how exactly you are transferring the Forvo pronunciation. Since you tagged this as Add-ons, are you using the addon below? The add-on page says it is dysfunctional, but for my usage, it works fine, no API key required.

You did mention Firefox. Are you downloading the file directly from the site, then doing a drag and drop into the note field? Are you using a Firefox addon? Either way, I recommend trying the Anki add-on I mentioned instead, although I haven’t tried it on Mac

Sorry, I mistakenly placed this in the add-ons category. @euie48, please start by updating to the latest Anki version to see if it helps.

Hi, I suggest we change the topic of this thread to: Problem with dragging files from browser (only Firefox?) into Anki.

I have the same issue as euie48, but in dragging mp3’s downloaded from Duden-website (German dictionary) from Firefox into Anki. (A flash card I’m making.) This used to work until recently.

I’ve tried to drag from Safari and from Finder (I’m also working on a Mac). Dragging from Safari and Finder works. So it seems to be a Firefox-related issue. The problem stays when I turn off all add ons in Firefox, and all add ons in Anki.

I hope there is a fix for this, because I prefer to work with Firefox.

This is the error message:

Anki 2.1.60 (76d88073) Python 3.9.15 Qt 6.3.2 PyQt 6.3.1

Platform: macOS-11.7.4-x86_64-i386-64bit

Flags: frz=True ao=False sv=2

Add-ons, last update check: 2023-03-20 07:56:49

Caught exception:

Traceback (most recent call last):

File “aqt.editor”, line 1267, in dropEvent

File “aqt.editor”, line 1296, in _processMime

IndexError: list index out of range

If you are hitting Download mp3 and dragging the file from the Downloads folder, that is just the file system, not the browser, right? (at least on Windows, not sure about Mac) Are you dragging from Downloads (in the Firefox Library area)? If so, did that work before?

Yes, actually, it did work before. But I have taken your advice and put the Forvo add-on back on and, so far, it seems to be working that way. The other way I have used is to download it to Finder and copy/paste it onto the Anki card.
I sure do appreciate all the responses and advice… Grazie mille!

1 Like

I finally was able to reproduce dragging from the Downloads area of Firefox on Windows, and it worked. Try the latest beta of Anki, 2.1.61 beta 2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.