Dragging and dropping picture error

Hello, I am trying to drag and drop a screenshot from finder on Mac into the back field of a basic card. This has worked for me consistently until now. When I try to do so, I get this error message:
An error occurred. Please use Tools > Check Database to see if that fixes the problem.

If problems persist, please report the problem on our [support site]. Please copy and paste the information below into your report.

Anki 2.1.65 (aa9a734f) Python 3.9.15 Qt 6.5.0 PyQt 6.5.0

Platform: macOS-13.4.1-x86_64-i386-64bit

Flags: frz=True ao=False sv=2

Add-ons, last update check: 2023-07-20 21:21:00

Caught exception:

Traceback (most recent call last):

File “aqt.editor”, line 1268, in dropEvent

File “aqt.editor”, line 1307, in _processMime

File “aqt.editor”, line 1320, in _processUrls

IndexError: list index out of range

I have tried using the Check Database tool and restarting anki while holding down the shift key. I also have the latest version of anki. How can I resolve this problem? Thank you in advance!

Anki is getting confused because there’s a URL on the clipboard, but it has no text in it. Drag&drop from the Finder works for me - maybe a system restart will help?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.