Error message when downloading add-ons

I attempted to download a couple different audio add-ons. One was Awesome TTS and the other was a forvo add-on. I tried this a couple weeks ago and it didn’t work, so I tried again with both today, and it still doesn’t. Instead, I get an error message saying the code is invalid, or that anki may not be up to date (I checked, and it is up to date). Any ideas what might be wrong?

You say it’s up to date, but which version exactly are you running?
This may be relevant: Linux Distro Packages - Anki Manual

I checked just now, and I’m running the official one. When I first downloaded Anki I was very carefully to avoid downloading the “offbrand” version, I figured it’d have more issues. Should I try uninstalling and reinstalling Anki?

Could you go in Help > About and post your Anki version?

The problem is that Anki is packaged by most Linux distribution very poorly, leading to most distributions having outdated versions. They all provide an official one.
However, no matter how you installed Anki, you should still update it for it to be updated (sounds legit?). Packages installed via your package manager are usually auto-updated, but if you manually installed Anki, you have to manually update it.

1 Like

Ah, well, I’ve already synced my decks and uninstalled Anki. I’ve been trying for the past hour or so to download the alternate version available in my app store, but it keeps failing to download. An error message pops up telling me to check my system for updates, reboot, and try again. Did all that, still doesn’t work.

I also tried downloading it from the Anki download web page. It’s not so much that it fails to download…but I cannot, for the life of me, get it to actually run.


I’ve followed the instructions found there, I’ve tweaked the commands in case I’ve been unwittingly doing things wrong, but I keep getting this as a result:

~$ tar xjf Downloads/anki-2.1.49-linux.tar.bz2 cd anki-2.1.49-linux sudo ./
tar (child): Downloads/anki-2.1.49-linux.tar.bz2: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

I put a portion in bold because I’m wondering if I’m supposed to actually put “anki-2.1.49-linux.tar-1”? Because that’s the title of my download. Although I will say, I have tried using that, and I get the same result.

Gosh, I just want to add audio to my mandarin decks in peace. At this point I might just suck and it up and use the version that actually manages to work

To help you with that I would need to know what’s your Linux distribution, and, in case you don’t use their default package manager, which one do you use?
For the first one, if you don’t know, please post the result of the command cat /etc/os-release, which will print the content of the file /etc/os-release (which contains the name of the distribution, its version and things like that).
For the second one, if you don’t know, please describe how you install packages. Do you run a command, or do you open a graphical application?

It’s really easy to install Anki, you’ll see, once you have located the archive you have downloaded. Do you know where the file that you download end up? Usually, they end up by default (for most web browsers) in ~/Downloads.
Once you have located that path, just do

$ tar xjf path/to/anki-2.1.49-linux.tar.bz2
$ cd anki-2.1.49-linux
$ sudo ./

(I have mimicked what you should see, please only type the commands. One mistake that you were making is that you were typing all the commands in the same line, which could not have worked in any case. Also replace path/to/anki-2.1.49-linux.tar.bz2 with the actual path to the archive).

Upgrading software in general is pretty important, so you should definitively learn how to do it. Anki is particularly difficult to deal with because, since version 2.1.15, the build system changed and the packagers struggle. The first time might be complicated, but then you’ll be able to do it on your own in five minutes.