Error message when attempting to pass/fail a card

Addons I am using
Fail pass
Heatmap

Not sure what has happened, but my anki has been coming up with this weird message, normally I just restart and it goes away but today if I try to use any flashcard the popup happens.

I have tried disabling all addons and the problem persists.

A few months back I did try to do a template clensing and deleted alot of old dead templates and tags, so I am wondering maybe if I accidently deleted one of the default templates that I need to use.

Debug info:
Anki 2.1.66 (70506aeb) Python 3.9.15 Qt 6.5.2 PyQt 6.5.2
Platform: Windows-10-10.0.22621
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2024-06-23 08:26:52

Caught exception:
Traceback (most recent call last):
File “aqt.webview”, line 46, in cmd
File “aqt.webview”, line 153, in _onCmd
File “aqt.webview”, line 665, in _onBridgeCmd
File “aqt.overview”, line 92, in _linkHandler
File “aqt.main”, line 713, in moveToState
File “aqt.main”, line 734, in _reviewState
File “aqt.reviewer”, line 166, in show
File “aqt.reviewer”, line 186, in refresh_if_needed
File “aqt.reviewer”, line 248, in nextCard
File “aqt.reviewer”, line 366, in _showQuestion
File “anki.cards”, line 129, in question
File “anki.cards”, line 145, in render_output
File “anki.template”, line 225, in render
File “anki.template”, line 272, in _partially_render
File “anki._backend_generated”, line 1200, in render_existing_card
File “anki._backend”, line 151, in _run_command
anki.errors.InvalidInput: missing template

Error messages like that usually start with –

An error occurred. Please use Tools > Check Database to see if that fixes the problem.

Did this one? Did you try that?

If that didn’t help – the next step would be to find the note type with the issue and eradicate it from your collection.

1 Like