Drag/drop images won't work

I’m not sure where to find my error message or if there even was one, but before today (I have the latest version as of this morning) I had no problem with dragging and dropping desktop images into my cards. I have a Mac. But after downloading the latest version:
i) I can’t drag and drop images in editing mode - I have to copy and paste
ii) In “add” mode it no longer lets me drag and drop images to the front of the card, and it only allows me to drag and drop one image to the back of the card. So subsequent images won’t take.
Any ideas on what to do? I’ve tried using the shift key but haven’t had much luck.
Thank you!!

Drag & drop functionality underwent a change in the recent version to fix an issue.
There should not be a difference between editting and adding modes.
I think the recent change made drag & drop require a bit more precision to work, so you should drop images right in the fields, and not anywhere in the editor screen.
It works for me without problems on Windows.

1 Like

I tried to be extra precise about it on my Mac…but it doesn’t work? is there anything else I can do?

Can you try dragging text instead of images?
Also try dragging an image from an external application (other than Anki) and drop it in a field, and do the same but with an image that’s already in your cards; drag and drop it in other field… Does it work? Is there a difference between the two cases?

I also have the latest version .31 and D&D function is working fine for me on Windows 10 2004 (latest). However, I also used to have same problem as yours and it used to happen when I was using D&D feature on different 2nd Anki which I opened with another windows account by using “Run as different user” which helped me using 2 Ankis at the same time. So if you’re trying D&D feature on 2nd instance of Anki which is opened with different windows account then it won’t work. D&D will work only on main Anki not 2nd Anki which is running simultaneously with the main Anki. So, if you’re doing same, then this should solve your problem.

I have tried dragging text - doesn’t work. although i never dragged text before so I’m not sure if I’m doing it right.
I’ve tried dragging screenshots in? those used to work as well but now they do not.
Sometimes the drag and drop works, other times it only works for the front side of the card, other times it works only for the back, etc. it’s really inconsistent which makes me wonder if this is some kind of bug?
@Aarkay i’m on mac OS.

thank you both!!

Please try running Anki from anki-console found in Anki’s folder.
After doing some dragging and dropping, post the console output here.

Screen Shot 2020-08-24 at 3.40.30 PM
I’m sorry but…I don’t know how to do that?
So sorry I hate to inconvenience anyone! I’m really new at anki and don’t have much experience with this kind of thing

I don’t know if this file (anki-console) exists on the Mac version. You may find it where Anki is installed (I don’t know where is the default installation path on macOS either).
It’s likely in the first folder (named Anki) in your screenshot.

1 Like

Screen Shot 2020-08-24 at 5.18.15 PM

So this is what i get when I click on it!

On Mac computers, recent Anki versions store all their files in the ~/Library/Application Support/Anki2 folder.


fScreen Shot 2020-08-24 at 6.54.00 PM

Hi, this is what I got! Thanks so much for your help btw

To view the console output on a Mac, please open Terminal.app and then start Anki by typing in


a warning/error may be printed there as you drag & drop.

Do you experience the same issue with both the standard and alternate Anki downloads on the website?

Screen Shot 2020-08-24 at 8.19.33 PM

I get this; it doesn’t look like I get an error message when dragging/dropping, I don’t think.
Do you mean, do I have the same issue when I try to make cards on anki web?

Screen Shot 2020-08-24 at 8.21.47 PM

Ok, that doesn’t reveal anything unfortunately.

I can’t seem to reproduce this on a Mac here. Do you use any third-party utilities that access the clipboard, such as a clipboard manager or dictionary tool? Would you be able to record a short video of what you see when you try to drop an image. You can use the Quicktime Player app to record your screen, and upload it on imgur.com

I’m having the same issue on my Mac. I can drag and drop before writing anything but once I start typing it stops working.

Recording shown here

1 Like

@dae, I think I figured out a possible cause of the issue:
Dropping something (images, text, etc.) over existing content on the fields doesn’t work. This is caused by using Document.elementFromPoint. We should probably use Document.elementsFromPoint instead.

Does this fix look right?

I opened a pull request.

1 Like

also yeah i think i’m having @richard 's issue in that it works even less when there’s text. still seems really inconsistent though

it never works when i’m in Browse and trying to edit a card