Download save failed: failed to persist temporary file

Whenever I try to sync, I get this popup anki_ioerror

Starting anki from the terminal doesn’t give me any errors.
Previous versions have worked fine.
I can also use 2.1.41 on an Ubuntu VM without any problems.
Searching google for this error message (and parts of it) doesn’t really help me.
Everything (Anki, OS, home directory) is on the same partition.
Building from source (with the anki-git package on AUR) also doesn’t resolve the problem

I have no idea where to go from here. Thank you for any help!

I am also facing the same error in Arch Linux.

Information regarding the devices in which I use Anki

1. Laptop (Arch Linux - installed yesterday) + Anki 2.1.41 + Python 3.9
2. Android 11 + AnkiDroid 2.14.5

My decks and cards are showing up fine in Ankidroid, but I am not able to sync them with Desktop version of Anki.

I am getting the following error

IOError { info: “download save failed: failed to persist temporary file: Invalid cross-device link (os error 18)” }

please help me resolve this.

Thanks for the report, a fix should be in the next beta

3 Likes

I am also on Arch Linux running KDE, receiving this error:

IOError { info: “download save failed: failed to persist temporary file: Invalid cross-device link (os error 18)” }

In fact, I couldn’t even get Anki 2.1.35 from the official repos to work; I could start it but it would show me a blank screen (sans menu options) and I wouldn’t be able to do anything except change preferences.

When running from terminal:

ERROR:network_service_instance_impl.cc(286)] Network service crashed, restarting service.
This would output endlessly.

I had to install the official Anki 2.1.41 build from the website, as I was not able to build the one in the AUR due to a Java issue.

However, I’m unable to sync with it.

Anki works fine on a machine running the version of Anki in the official repos using the same up-to-date packages on Arch except it’s using GNOME, not KDE.

I can upload fine on the KDE machine, but I can’t download.

I just tried the anki-git package from the AUR again, and it’s working again. Thank you for the quick response!

I’m facing the same error on AnkiMac. Can anyone help?

What’s the exact text you’re seeing, and what action are you taking when it appears?