Anki Forums

Deleted add ons

Hello

I recently updated Anki from 2.1.26 to 2.1.33
I had to do this since Anki wouldn’t work otherwise.
Since then all my add ons have been lost. (flashcards are fine) I have tried opening backups with 2.1.26 however Anki doesn’t work at all. I am currently using a Mac.

Any help retrieving my add ons would be much appreciated.

Incompatible add-ons are not deleted, but they are disabled until they are updated to work with the newer Anki version.

Thank you for your reply, so they should just pop up automatically when they are updated by the creator?
My add on list is just blank at the moment so I wouldn’t be able to update them myself.

Disabled add-ons should still be visible in the list. If you don’t see any add-ons, maybe you were storing your data in a different folder location in the past?

Yes the list is blank. Any ideas of where they could be?
All I did was update the app!

This is really strange, but updating Anki shouldn’t result in an empty list of the add-ons. Maybe some other app removed addons21 by mistake but I’m not sure.

I guess, you’ll need to redownload your add-ons again from AnkiWeb.

About opening backups with 2.1.26, this is being mentioned on the download page and probably related.

If downgrading from a newer version because you use an add-on that hasn’t been updated yet, please make sure you use the Downgrade & Quit button first .

1 Like

Thank you for the info! Perhaps they were somehow removed but I have no idea how. I had a look at my previous backups, for the folder Anki2 and they are all empty no matter how far back I go. I tried the Downgrade and Quit button too but that didn’t seem to help either.
I suppose I will just have to re download all the add ons.

Sorry, I think, I made a mistake in my previous message. If you want to open backups with Anki 2.1.26, but they were created with Anki 2.1.33, it’d be easy to temporarily install Anki 2.1.33, open one of your backups, use the Downgrade & Quit button, and install Anki 2.1.26. But since your flashcards are fine, there’s no need to do it.

About the add-on, yes, I think, re download all the add-on is the only way.

1 Like