Debugging Permission Problems

Debugging Permission Problems.

I don’t know why, but I can’t import my file to an Anki.

It gives me an error which says access denied.

That happen after I reinstall Windows 10.

I made those things which was said in the manual, but problem is still there.

Anki manual said to pin this to my support ticket.

  1. Can you give us the exact text of the error – or a screenshot of it?

  2. Are you using alternate (non-default) locations for either the Anki program install, or for the Anki2 data folder?

  1. I haven’t seen this before. It looks like some sort of permissions index for your collection.media? What command did you run to get this? How is this related to your issue?

  2. Tell us more about what your import process is. Start with whether you are importing an apkg, or a text file.

  3. Paste the information from Help > About > Copy debug info.

1 Like
  1. “500: Failed to read ‘C:/Users/0/Downloads/’: Access is denied. (os error 5)” - that full text. And the screen itself is white.

  2. I didn’t touch location of Anki during installation, it’s default. I just installed the program as usual by clicking next.

  3. Firstly I get this from there Permission Problems - Anki Manual I have tried to do “Permission Problems” part but it didn’t help than I did that part “Debugging Permission Problems”. That second part said I need to run this:
    whoami
    cd %APPDATA%
    icacls Anki2 /t
    And that what I did. And also it said I need to take a screenshot and ask help further from Anki ticket system.

  4. I download TSV file from Google Spreadsheet.
    Then I import that file into Anki.
    I always did it like this, and it worked, except that moment.

  5. Anki 24.06.3 (d678e393) (ao)
    Python 3.9.18 Qt 6.6.2 PyQt 6.6.1
    Platform: Windows-10-10.0.19045

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Review Heatmap [‘1771074083’, 2022-06-30T04:43, ‘None’, ‘’]

===IDs of active AnkiWeb add-ons===
1771074083

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

  1. Thank you for willingness to help and answering on my ticket.
    Anki is #1 app for me, and I have no idea how would I live further without it.
    I am a non-native English ‘speaker’. Sorry for my illiteracy.

I reinstalled my Windows 10.

And first thing which I did I tested import of TSV file to Anki.

And unfortunately i get the same error.

“500: Failed to read ‘C:/Users/Sky/Downloads/’: Access is denied. (os error 5)”

For now I manage to solve this by using older version of Anki.

I have created a support ticket on GitHub in attempt to report this bug.

1 Like

You could try running icacls after doing ‘cd \users\sky\downloads’, since it seems to be the downloads folder that’s causing troubles.

1 Like