Cloze Cards not appearing in iOS

Hello,

This is my first post here, I searched the forums for a solution but could not get things to work.

I recently bought the iOS version of Anki and for whatever reason, when I have a Cloze on the front side of the card, when I flip the card, the answer doesn’t show. There is no mention of any Clozes missing but the card is just blank. It works perfectly fine on desktop. The card style I am using is Anking-Overhaul. I tried making a basic card with a Cloze and the answer still doesn’t show. I tried enabling adding Mobile class and checking the CSS but can’t seem to figure it out. Any insight would be appreciated.

I would have thought it was a template issue (perhaps text/background color issues), but that doesn’t mesh well with it happening on multiple Cloze note types.

Have you already tried switching between themes/night mode/dark mode for the app? That will clarify that there isn’t a color-matching night-mode/inversion issue.

I am loath to poke around in dense Anking templates :sweat_smile: , so let’s just talk about your simpler one first.

To clarify – did you create that note with a Cloze note type? Or did you add a {{c1::cloze deletion}} to a non-Cloze note? As long as it was the first one – let’s try taking a look at (1) the templates – front, back, and styling (in a code/preformatted block please), (2) the contents of that note, and (3) screenshots of how it displays for you.

If you edit a problem card using the computer version, click Cards…, and use the Options button to ‘add mobile class’, you’ll see that the card template has been misconfigured to hide the cloze on the back side on mobile. Removing the following from the styling section may help. If not, please contact the deck author for assistance.

.clozefield,

.mobile .editcloze {

display: none;

}
2 Likes

Thank you so much, this did the trick! Thanks for everyone’s help

1 Like