Can't open options or preferences, can't synchronize

I get this error message when I click on options for a deck:

Anki 2.1.15 (442df9d6) Python 3.10.2 Qt 5.15.2 PyQt 5.15.6
Platform: Linux
Flags: frz=False ao=False sv=1

Caught exception:
File “/usr/share/anki/aqt/”, line 213, in
a.triggered.connect(lambda b, did=did: self._options(did))
File “/usr/share/anki/aqt/”, line 242, in _options
File “/usr/share/anki/aqt/”, line 868, in onDeckConf
aqt.deckconf.DeckConf(self, deck)
File “/usr/share/anki/aqt/”, line 25, in init
File “/usr/share/anki/aqt/”, line 49, in setupConfs
File “/usr/share/anki/aqt/”, line 66, in loadConfs
File “/usr/share/anki/aqt/”, line 89, in onConfChange
File “/usr/share/anki/aqt/”, line 175, in loadConf
<class ‘TypeError’>: setValue(self, int): argument 1 has unexpected type ‘float’

I am on Fedora 35, and I installed Anki from the Fedora repositories. I haven’t installed any addons, but I have imported notes from spreadsheets. I also use Ankidroid.

I tried to check the database but nothing happened. When I synchronized, all my decks were emptied.
I initially deleted my Anki account, and created a new one to start over, but the problems persisted. Now when I try to synchronize it just gives me a login prompt, but nothing happens when I try to login.

Would really appreciate any help!

Updating your Anki may fix the issue (maybe try the official build).

Relevant past threads:

1 Like

Thanks, that solved it. I didn’t realize the Fedora version was so far behind.