Can't change note type

Hi everyone. Is there anybody who could help me with an issue?
I am not able to change the note type of certain cards. It only applies to cards I downloaded from LingQ. Also, it only happens on Anki 2.1.45 and higher. The previous versions had no trouble with these cards.
When I try to change the note type a window opens. It’s blank, though.

Can you provide more details?

1 Like

Of course, I can. :slight_smile: I use windows 8.1. It is not connected to your operating system, though. This problem is occurring on Macs and newer versions of Windows, too.

Great, thanks.
Have you tried deactivating add-ons?
Does “Change notetype” work as expected with other note types?
Could you share a sample card?

Yep, I have tried to deactivate the add-ons I have, besides other cards work fine. Here are the cards. lingqs.apkg |

The notetypes appear to have been created with a third-party tool, and they don’t have the format of id that Anki expects. Please contact the deck/notetype author to report the issue and ask them for help.

Thank you for your answer. Is there anything else what they should know to fix that? Is there anything I can do to fix the cards I already have?Also, I was wondering why this issue has been occuring since the 2.1.45 Anki update. Previously those cards worked fine.

The ids should be timestamps, not random 64 bit numbers, and the fact that the latter worked in the past was just happenstance. If the person responsible for the notetypes can not help you, you should be able to work around the issue by changing the notes to a new notetype using an older Anki version.

Hi, @marketa.kalacskova
have you figured out a way to change the note type?

Hi, I haven’t. I reported this issue to the Lingq support, they promised to look into that. So, I am using Anki 2.1.44 for the time being.