Cannot open tools->preferences

I just installed the latest version of Anki on Linux Mint. When I tried to do a sync, I received the error message “Your Anki client does not support the new timezone handling yet. Please ensure your Anki is up to date.”
I’ve read that one possible solution to this is to change the timezone settings in preferences, however, when I try to open preferences I get the following error message:

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.15 (442df9d6) Python 3.10.6 Qt 5.15.3 PyQt 5.15.6
Platform: Linux
Flags: frz=False ao=False sv=1

Caught exception:
File “/usr/share/anki/aqt/”, line 882, in onPrefs“Preferences”, self)
File “/usr/share/anki/aqt/”, line 82, in open
instance = creator(*args)
File “/usr/share/anki/aqt/”, line 25, in init
File “/usr/share/anki/aqt/”, line 80, in setupCollection
<class ‘TypeError’>: setValue(self, int): argument 1 has unexpected type ‘float’

I have checked the database as suggested but that did not cure the problem.

Update I reinstalled Anki and tried using the Flatpak version instead – this works without any problems.

That’s not the latest version. The latest stable release was 2.1.54. It seems like your distro hasn’t updated Anki in its repository for a long time.

It is recommended to manually install Anki instead: Install & Upgrade - Anki Manual


Thanks, 2.1.54 is what I now have after installing the Flatpak version - you’re right, it looks like the main repository for Linux Mint has not been updated for a while.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.