Cannot change language input when making new cards

Hi all, I haven’t been able to change the language input from the English keyboard ever since I went from Windows to Linux Mint (20.2 Cinnamon). I can switch the language input on my browser and on text editors, just not Anki. I’m on version ⁨2.1.40.

Bump, I’d really love an answer ^^

What input method are you using? Anki supports Fcitx according to Input Methods - Anki Manual

I also remember that IBus used to work for me (years ago when I last tried).

Thank you for the reply!

I was using Fcitx, and I even tried going to the beta version with Python, and it still didn’t work. I just tried IBus, and even though it shows on the popup window that the language is changing, the input is still in English in Anki.

IBus should work if you have the env vars set right. fcitx may work if you follow the steps on Add Fcitx5 Support

I wasn’t familiar with using env vars so I followed the steps on the other thread. I was on Ubuntu so I couldn’t copy-paste the commands that were listed, but it was easy enough downloading and copying the plugin in through the file system. And now it works! Thank you so much, you’ve made my day ^^

1 Like