Bug in "remove tag" in browser

It used to be that removing a tag will only remove the whole string of tags chosen in the pull-down list, without any odd behavior. But now, in v2.1.30, it results in removing only a portion of the named tag, resulting in very bad and odd-looking tags. e.g.:

Suppose I have an entry with this existing tag:

If I remove this tag (choose it from the drop-down list):

Results observed: one of the three possibilities of tag left after the remove operation:


The results were unintended.

Note that the caret symbol (^) is a legitimate character that can be used in the tag name.

I tried with 2.1.30 and I cannot reproduce this issue. ^study^math tag is removed as expected. Can you confirm you don’t have non-printable characters i.e. control characters in the string?

Hi Guillem,

Thanks for the reply. I tried to make a video to reproduce the problem myself, but this time it worked fine. Correct, I don’t have control chars in the tag name (I don’t know how to generate such a character.) I’ll come back if this issue can be documented with screenshots or video recording, if it happens again.

Usually that hapens when pasting text from other sources.


It’s fixed in the 2.1.31 betas.

1 Like