Black screen - tried all solutions and it's still not working

Hi, I was running Windows 7 32-bit and Anki used to work fine, until I recently added a really large deck and Anki stopped working, it opened but it showed a black screen
I removed that deck in AnkiWeb and tried to resynchronize Anki but it kept showing a black screen
I had also installed a few addons, but I removed all of them
I thought it was because I was using 32-bit, I recently upgraded to 64 bit and installed the latest version, 2.1.35, but I received the error “Fatal Error detected: Failed to execute script pyi_rth_multiprocessing”, so I downgraded to the version 2.1.15
When I opened it the screen stayed black
So I thought something was wrong with my entire collection, so I deleted the Anki2 folder in %APPDATA%, and yet the issue persists
I tried what others tried like resizing the window, maximizing and minimizing it, didn’t work
I tried the cmd commands in, it didn’t work either
I tried all 3 with hardware acceleration turned off and on, didn’t work
What else can I try?
Anki black screen

@dae please have the goodness to take a look

Maybe updating to Windows 10 will help.,more%20vulnerable%20to%20security%20risks.

I agree that it might help but Windows 10 uses 2GB of RAM in the idle state with nothing running in the background, I can’t afford to waste that much RAM on nothing, Windows 7 only uses 500mb
Is there any other solution? Please?

I’m sympathetic, but I’m afraid I can not reproduce the issue, and do not know why some Windows 7 machines have this problem.

1 Like

Ok, no problem
Is there an old version where this issue didn’t exist? Maybe back in the v1.x ones?

About Anki 2.1.15, since everything worked fine before, try:

  • to start Anki with -b option and specify a new folder, e.g. "C:\Program Files\Anki\anki.exe" -b "C:\AnkiDataFolder"

  • Open %USERPROFILE%\AppData\Local\Anki in the Windows Explorer and remove everything from it. It should contain cache and QtWebEngine folders.

    It can be opened with Win+R or press Ctrl+L in the Windows Explorer to edit the addres bar, or click on it.

About Anki 2.1.35-standard, assuming you’re on Windows 7 SP1, try to follow “Install problems” on and

try manually installing this update and then this update.

If it won’t help, install Windows x86-64 executable installer from Python Releases for Windows | and check “Add Python 3.8 to PATH” during the installation process and then try to open Anki again.

If it won’t help, try to run Anki from wheel.

If you want to run Anki from a local Python installation but don’t want
to make changes to the source code, you can install pre-built packages from PyPI.

$ python -m venv pyenv
$ pyenv/bin/pip install aqt anki ankirspy pyqt5 pyqtwebengine
$ pyenv/bin/python -c 'import aqt;'

On Windows replace pyenv/bin/ with pyenv\Scripts\ and replace ' with ", i.e.

python -m venv pyenv
pyenv\Scripts\pip install aqt anki ankirspy pyqt5 pyqtwebengine
pyenv\Scripts\python -c "import aqt;"

It might take about 15 minutes.

And maybe try to reinstall or update your graphics card driver.


I really appreciate your answer but
Anki is a huge part of my life and I need it a lot, so I updated to Windows 10
I can’t try your solutions anymore
I’ll leave troubleshooting this issue to whomever faces it in the future.

1 Like

I figured out why this is happening
It started happening even after I updated to Windows 10, the screen would be blank for a long while but then it loads
I deleted a really large deck I downloaded before and it stopped happening
So it was a case of it loading a really large deck (it’s basically a steno dictionary) from a slow HDD.