Anki deskopt´s screen is all black

“When I double-click on the Anki icon, the screen is all black. I tried different versions and searching for the error on Google, but couldn’t find anything useful. I have copied and pasted the screen to the bottom of my post. What should I do?”

So Damien told there is no solution for that now. But if you just download the alternate version the problem will be solved.

don’t know what causes it, never had this issue. if the alternate version doesn’t solve your proble, you’ll have to wait until Damien (or someone who has experience with this problem) gives you an answer.

[Anki for 32 bit Windows 7/8/10 (2.1.26-alternate)] not working, also black screen

[Download Anki for 32 bit Windows 7/8/10 (2.1.22-alternate)] gives me this error

image

install the version that you had installed, then go to File -> Switch profile. click on Downgrade and quit then install this alternate version.

still black :frowning:

i tried 64 bit Windows 7/8/10 (2.1.26-standard)] with 32 bit Windows 7/8/10 (2.1.22-alternate)]

and also [Anki for 32 bit Windows 7/8/10 (2.1.26-alternate)] with 32 bit Windows 7/8/10 (2.1.22-alternate)] doing what you said and the screen is still black.

you should probably wait until @dae answers you.
i have never had this issue, and don’t know what causes it, or how to solve it. sorry

1 Like

@mmdj2 thank you for trying! @dae please help me! :cry:

Chances are one of the three possible video drivers will fix the issue: https://changes.ankiweb.net/#/known-issues

Tengo windows 7, 64 bits. Cuando descargo las distintas versiones y abro el programa la pantalla aparece toda negra, busque por todos lados y no encuentro la solución ¿Alguna idea? Desde ya gracias!!
Anki screen|690x387

still not working :frowning: It says that the file cannot be found

If you change the hardware acceleration option in the preferences screen then it will create the gldriver file.

1 Like

Hey, dude, do you know a solution this important problem?

Hi.

I have the exact same problem since I upgraded to Windows 10 version 1809.
Computer = Dell 7400 2-in-1, Intel UHD 620.

I tried the following :

  • Use anki-2.1.35-windows-alternate

  • Upgrade to Anki last version 2.1.41.

  • Upgrade the Intel driver to last version from Dell for my computer (27.20.100.9126)

  • With gldriver = software : image
    In anki-console, I’m getting the following error :
    Qt critical: ARB::createContext: wglCreateContextAttribsARB() failed (GL error code: 0x0) for format: QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile), shared context: 0x1 (The operation completed successfully.) Qt critical: GDI::createContext: wglCreateContext failed. (The operation completed successfully.) Qt warning: Unable to create a GL Context.

  • With gldriver = auto and gldriver = angle : the following error message is raised in anki-console
    Qt warning: QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings

I have no clue what else to do.

Would anyone have an idea ?

Thanks in advance.

If none of the available drivers work, and updating to the latest Windows and latest video drivers does not help, I’m afraid I’m out of ideas.

Thanks for giving a look.
I’ll try using another computer, even if it’s not the most comfortable solution :slight_smile:

This worked for me, I changed the Color Settings in the Intel Graphics Control Panel, from 16 bit to 32 bit. I have a win 7, 64 bits. Using version 2.1.44.

I’m surprised 16 bit color is still even an option in 2021. Thanks for taking the time to post your solution.