Anki won't let me change to cloze deletions

Hi everyone,

I think I accidentally changed the notetype of my entire deck and this means that I can’t create a Cloze card anymore. My pre-existing cloze cards in the deck do not work. I have read other threads on here and tried to change the notetype of an individual card but the {{c1::…}} information doesn’t appear. I am fairly new to Anki and have no idea what I am doing so would appreciate any help!

The below screenshots are the examples. If I change the front template to say {{cloze:Text}} then it says I am missing a field. Is there a way to change this for all the cards in the second photograph?


You can’t do that without selecting which part of the text needs to get clozed. How do you think Anki will know that?

Do you have local backups? Or if you haven’t yet synced then you can just sync data from Ankiweb which would replace your collection with data from the web.

That’s expected. Your field is called “Front” not “Text” – so {{cloze:Front}} is correct for your template.

What is not working about them? When you click “Preview” (on the right above the note editor), what do you see?

You can always add the basic note types again.

The author of the topic does not use the closed entry type.
“Cloze deletion can only be used on cloze notetypes.”
Most likely this is a different type of record renamed closed.

Because card generation functions differently for cloze deletion cards, {{cloze:…​}} tags can not be used with a regular note type - they will only function properly when used with a cloze note type.


I see that error and the missing toolbar section now. [Odd that in the template editor that card appears in preview just fine. :thinking:]

Yes, I agree with you – this note type must be mis-named then.

@michael.abe – if you need more specific steps –

  1. Change the name of this “Cloze” note type to “DeleteThis” (or something) – Notes > Manage Note Types > Rename
  2. Create a new note type that works correctly – Notes > Manage Note Types > Add > “Add:Cloze”
  3. For all notes with note type “DeleteThis” – Notes > Change Note Type > “Cloze”
  4. Delete the misnamed note type – Notes > Manage Note Types > select “DeleteThis” [which should be used by 0 notes now] > Delete

What did you guys understand from his post? I thought he was saying that he is trying to change his note type to cloze and the clozes aren’t appearing.

{{c1::…}} information doesn’t appear.

These are not closed notes
Check out the link and the quote that I left above.

Oh okay. Now it’s making sense. But the template appears about right though? I thought I could just type in {{cloze:Front}} and it become cloze. Anyways, I actually checked and {{c1:text}} do not appear in previewer as clozed text unless you use a cloze note type. So why is it working here? Weird.

The cloze note type functions differently from regular note types. Instead of a customizable number of card types, it has a single type which is shared by all cloze deletions on a note.

I think it was convenient in technical terms.
For other types of notes, you specify how many cards to create, but with the closed type of note, everything works differently.

Thank you very much! I tried something similar earlier but it didn’t work but your clear steps sorted my issue. Thank you for your patience!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.