Anki window blank

The issue manifests as everything but the main window content being visible when I start Anki. The menu bar is visible, and when I open settings, everything there is visible, and the syncing window is visible when I sync. If I press s (shortcut for going into a deck), it’s still blank. When pressing a for adding a card, the adding card-window is partly blank, see attached photo. When I move from one view to another, such as on starting or on trying to go into a deck with the s key, the content part of the window (below menu bar) blinks white once.

System is Arch Linux, wm is dwm. I’ve tried setting different Qt themes.

Running from command line, I get some errors. It’s basically this repeating multiple times:

  File "/usr/bin/anki", line 19, in <module>
  File "/usr/lib/python3.10/site-packages/aqt/", line 437, in run
  File "/usr/lib/python3.10/site-packages/aqt/", line 616, in _run
    mw = aqt.main.AnkiQt(app, pm, backend, opts, args)
  File "/usr/lib/python3.10/site-packages/aqt/", line 131, in __init__
  File "/usr/lib/python3.10/site-packages/aqt/", line 182, in finish_ui_setup
  File "/usr/lib/python3.10/site-packages/aqt/", line 48, in draw
    self._body % self._centerLinks(),
  File "/home/simon/.local/share/Anki2/addons21/24411424/", line 562, in cs_toolbarCenterLinks
    tip=tr(TR.ACTIONS_SHORTCUT_KEY, val=config_scuts["main stats"]),
  File "/usr/lib/python3.10/site-packages/anki/_backend/", line 155, in __call__
please use tr.message_name() instead of tr(TR.MESSAGE_NAME)

Does the error message look related to the error? Anki doesn’t crash.

Potentially related to these topics (although they are on mac):

forums ankiweb net/t/see-nothing-when-i-open-anki-on-mac/7014
forums ankiweb net/t/anki-opens-but-all-windows-are-blank/8920

Sorry, not allowed to post links but you can figure out what it’s supposed to be.

Have you tried installing the official packaged build from

See: Third party Linux packages and source builds are not supported / Anki Ecosystem / Knowledge Base - AnkiMobile/AnkiWeb Support


That’s a good suggestion. I installed the official package and the content is there again.

I still get the same error output in terminal when running Anki. Anki also seems to ignore my Qt theme even when I start it with something like QT_STYLE_OVERRIDE=Breeze anki

The problem I asked about is solved to, so I’m closing.