Anki Forums

Anki sync fails on and off for a week now

Hi,

For about a week, I’ve been experiencing syncing problems with Anki Desktop. I was using version 2.1.33 and sometimes I would get an error message “a network error occurred”, it said it was os error 10060.

Thing is, it would fail to sync one minute, but after I try to sync again 5-10 minutes later (and sometimes, immediately after the first failed attempt) the sync would succeed. But then a few minutes later it again shows the same error message, and so on repeatedly, on and off.

At first I thought it might be a problem with Anki or the network or something so I waited but after a week of experiencing this annoying problem I tried to solve it.

I first upgraded to beta version 2.1.34 yet the problem persisted. I then tried downgrading to stable version 2.1.26 but now I’m getting a different on and off error message when attempting to sync: “syncing failed: The connection to AnkiWeb timed out. Please check your network connection and try again”.

When I press “sync” Anki pops a window that displays the message “connecting…”. If the sync succeeds then it then continues to show “syncing…” while uploading and downloading data and then it finishes. If the sync fails it doesn’t show the uploading\downloading bit at all, but is stuck on the “connecting” phase for a while before showing the error message above.

What does that mean and how can I fix it? My internet is working fine and Anki is the only thing I’m having trouble with.
Please help, this is all very frustrating.

Thanks.

It’s probably an issue with an international link: https://faqs.ankiweb.net/syncing-failed-connection-timed-out-errors-when-syncing.html