Anki shows a blank window

I just installed Ubuntu 22.04. I had already been using Anki 2.1.49 and I keep my home folder from one release to the next, so I just tried to start Anki 2.1.49 from there. I also installed it system-wide.

At first it wouldn’t open at all, so I tried ‘QT_DEBUG_PLUGINS=1 anki’ as suggested on the Anki website. On the basis of the output from that command, I then did ‘sudo apt-get install libxcb-xinerama0’.

Now Anki starts, and when I click on open it appears to sync my collection from Ankiweb. But then I only get a blank window with the menu items “File Edit Tools Help”. If I click on Tools - Study Deck it shows all my decks, but if I select one and then click on “Study” I just end up back at my empty window.

It seems to be some sort of display problem, but ‘QT_DEBUG_PLUGINS=1 anki’ doesn’t suggest to me that there is anything else I need to install.

It all worked perfectly on Ubuntu 20.04. Can anyone suggest what I need to do next?


You could create a shell script to start Anki with the --no-sandbox flag:

export QT_QPA_PLATFORM=xcb
anki --no-sandbox

QT_QPA_PLATFORM=xcb prevents Anki from running in Wayland. That’s optional of course, but I recommend it because Wayland isn’t a good experience yet.


That’s solved it! Thank you so much for your suggestion.


This worked for a while for me but at least as of today has stopped working. Did anyone else experience this?

This is for Arch Linux.