Anki on Arch Linux - two application-breaking problems

Hello, I’m a longtime user of both Anki and Arch and have only recently been running into problems. This is frustrating as it has disrupted my language learning process.

Previously I was using the anki-official-binary-bundle package from the AUR. The current version is 2.1.49-1. Now that application only loads a blank window:

I decided to switch to another version of the Anki package, as there are several available. anki-git (version 2.1.50) is the other one which works, but it seems to have broken one of my decks, unfortunately the main one I use. When I review a card, every answer sets a 1-day interval:

I have looked through various options and whatnot to see if this is something that I accidentally enabled but it doesn’t seem to be the case. I also don’t seem to have created a custom study session by mistake.

I have also tried flatpak which has its own issues. I am hoping someone can help me find a way to make Anki function correctly. I don’t care which way it is, just that I can go back to my daily vocabulary reviews. Thank you!

Have you tried simply downloading anki from the official website and trying that version? Seems like the obvious thing to try.

The blank window seems to be an issue due to the upgrade of glibc from 2.33 to 2.35

Running anki with --no-sandbox or QTWEBENGINE_CHROMIUM_FLAGS="–no-sandbox" should work


For the other issue, can you share a 1 card deck that demonstrates the problem?

(assuming it happens when add-ons are disabled)

1 Like

Thank you, this takes care of the issue. I’ll just include that tag when I run Anki, probably forever

It turns out the 'Maximum Interval" option got set to one. I’m not sure how because I know I have never done anything with those options before. All is well! Next time I’ll know where to look.