Anki in Wayland

So I tried running Anki in KDE Plasma 6 and the fonts are blurry. I have a 125% scaling in KDE and Anki. Even with 100% scaling in Anki the fonts are blurry. In legacy X11 Applications I have the set the applications to apply scaling themselves

I see the following lines in command line:

Qt warning: The cached device pixel ratio value was stale on window expose.  Please file a QTBUG which explains how to reproduce.

Is there a way to fix it?

Does this help? Wayland - Anki Manual

Wayland support is not ready

See Wayland issues · Issue #1767 · ankitects/anki · GitHub for discussion and bug reports


i will just run in X11 mode with QT_QPA_PLATFORM=xcb variable until the bug is fixed

Did the variable QT_SCALE_FACTOR_ROUNDING_POLICY=RoundPreferFloor did not work? or is it another problem with fractional scaling?

1 Like

I tried it now and it works :slight_smile:

1 Like

Hi. I am also getting the blurry fonts in wayland (hyprland)

export QT_QPA_PLATFORM=wayland

in ~/.bashrc
one of those fixed the error message OP was getting but the weird blurry font persists

update : the conjunction of the following 2 lines in hyprland.conf fixes the issue…




where INTEGER is any positive integer.

the problem with this solution is that everything else scales with the monitor setting, and 1 is too small while 2 is too big. The rounding policy environment variable doesn’t seem to work

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.