Anki glitch showing previous card answer instead of new card

Hi folks,
I’ve looked all around and tried to find this problem but couldn’t, although I might not be looking in the right places.
My Anki is glitching on my laptop (PC) - a card will appear, I’ll press spacebar to reveal the answer and its answer will appear. I will then click on a level of difficulty. Instead of a new card popping up, the previous card with answer revealed (i.e., the exact same screen I was just on), shows up again. Then I’ll hit the space bar and the answer for the card that was supposed to be the next card (although it didn’t really appear) will show up.

Any help/guidance would be appreciated. Thanks.

Changing your video driver in the preferences screen to ANGLE or software may help.

1 Like

I have no idea what that is or what it does, but it has worked to correct the problem so far! Thank you very much for taking the time to reply!!!

1 Like

Made an account just to say that this worked for me as well and I am so grateful to you because this was annoying the ever living crap out of me.

1 Like

Thank you for this, I just tried it and fingers crossed the solution takes.

I tried switching to software using the command prompt and the app wouldn’t launch. I am using version Anki 2.1.50+ Qt6. Are there any other solutions? The problem came with the new update. This problem is occurring on both desktop (Windows) and Anki mobile (iPhone).

If you have no luck with the -Qt6 version, you could try -Qt5 instead, and try the ANGLE video driver in the preferences.

I am having the same problem after updating to -Qt6 version. How do you enable ANGLE video driver? I don’t have it in my preferences.

https://docs.ankiweb.net/platform/windows/display-issues.html#qt6

I just installed the -Qt6 and started seeing this problem. Every few cards, if I hit Good or Again, it shows the previous card (already answered) instead of advancing to the next card. Anyone else have this issue? I saw some advice online to download ANGLE driver in my preferences, but mine doesn’t seem to have this option? Any help would be appreciated!!
EDIT: I’m also having an issue where Anki lags for several seconds before advancing to a new card. I’ve never had these issues before.

I did as the link instructed and while the issue has resolved for the most part every so often (every ~100 cards), I bump into the same issue where pressing Good shows the previously answered card.

The webview is reloaded every 100 cards as it used to leak memory. That may no longer be the case; I will experiment with turning that off in the next beta.

So, I am the OP for this topic, and while the ANGLE video driver solution worked for the old version, I have Qt6 and am now having the same problem again. Unfortunately, I have basically zeo programming skillz and don’t understand what this link is telling me to do - or where to do it. So, specifically, my questions are a.) what does this mean - echo software > %APPDATA%\Anki2\gldriver6, and b.) where do I go to revert to the default behavior and change “software” to “auto”? Any help would be much appreciated! Thanks!

1 Like

You need to run cmd.exe, then enter that text into it and press enter. Replace software with auto to revert the change.

I’m having the same issue as you. I am just switching to the previous version of Anki for now. I went through all of the suggested steps, including restarting Anki and uninstalling and redownloading a few times. I’m done studying for the night, but hopefully tomorrow the issue will be resolved for me. It does throw off your study flow when you see the previous card instead of a new one. Cool that there is a forum for this. Anki is saving my butt in PA school!