Anki does not auto switch to night mode in Mac OS

From my understanding Anki should switch between light and dark mode as my Mac OS system switches from light to dark mode, but my Anki just stays on light mode. It only switches to dark mode when I manually configure night mode in the top menu, but even this leaves the toolbar in light mode.

I’m on Anki 2.1.35
Mac OS 10.15.7

I’ve tried restarting my computer, deleting and re-installing anki, and disabling all of my add-ons but nothing has worked so far.

Sorry, automatic switching is not possible at the moment.

1 Like

Hello Dae,

Thank you for the reply anyway. I have exactly the same setup and the same issue. Do you think automatic switching will be available in the future?


Probably not in the short term.

Could I use this build?

Night mode:

  • The night mode option in the preferences screen now turns the interface dark as well.
  • On macOS, when the system is in dark mode, Anki will switch to night mode automatically.